summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-02-20 15:33:04 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-02-20 16:46:21 +0200
commit1fc06abe99d93113988ffe77caed2ca451404c45 (patch)
treeefa0f5b7bb195be73ce99c60d1e612a6a96e10af /dev-util
parentapp-office/scribus: Stabilize 1.5.8-r5 amd64, #893488 (diff)
downloadgentoo-1fc06abe99d93113988ffe77caed2ca451404c45.tar.gz
gentoo-1fc06abe99d93113988ffe77caed2ca451404c45.tar.bz2
gentoo-1fc06abe99d93113988ffe77caed2ca451404c45.zip
dev-util/hfstospell: include upstream gcc-13 patch
Closes: https://bugs.gentoo.org/894730 Closes: https://bugs.gentoo.org/895508 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/hfstospell/files/hfstospell-0.5.3-gcc-13-fix.patch21
-rw-r--r--dev-util/hfstospell/hfstospell-0.5.3-r1.ebuild52
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-util/hfstospell/files/hfstospell-0.5.3-gcc-13-fix.patch b/dev-util/hfstospell/files/hfstospell-0.5.3-gcc-13-fix.patch
new file mode 100644
index 000000000000..d5dc32d57a7e
--- /dev/null
+++ b/dev-util/hfstospell/files/hfstospell-0.5.3-gcc-13-fix.patch
@@ -0,0 +1,21 @@
+From 7481bffbf622bc9aee3547183fbe8db9cf8b22ce Mon Sep 17 00:00:00 2001
+From: Tino Didriksen <mail@tinodidriksen.com>
+Date: Sun, 3 Jul 2022 23:16:52 +0200
+Subject: [PATCH] Include cstdint (fixes #57)
+
+---
+ hfst-ol.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/hfst-ol.h b/hfst-ol.h
+index 0a83ec5..ee59b14 100644
+--- a/hfst-ol.h
++++ b/hfst-ol.h
+@@ -28,6 +28,7 @@
+ #include <climits>
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstdint>
+ #include <iostream>
+ #include <cstring>
+ #include <set>
diff --git a/dev-util/hfstospell/hfstospell-0.5.3-r1.ebuild b/dev-util/hfstospell/hfstospell-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..80b70860f0f0
--- /dev/null
+++ b/dev-util/hfstospell/hfstospell-0.5.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="HFST spell checker library and command line tool"
+HOMEPAGE="https://github.com/hfst/hfst-ospell"
+SRC_URI="https://github.com/hfst/hfst-ospell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="clang"
+
+DEPEND="app-arch/libarchive:=
+ dev-libs/icu:=
+ !clang? (
+ dev-cpp/glibmm:2
+ dev-cpp/libxmlpp:2.6
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ dev-libs/libxml2
+ )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/hfst-ospell-${PV}"
+
+PATCHES=( "${FILESDIR}"/hfstospell-0.5.3-gcc-13-fix.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # https://github.com/hfst/hfst-ospell/issues/48
+ if tc-is-clang; then
+ econf --without-libxmlpp --without-tinyxml2
+ elif use clang; then
+ econf --without-libxmlpp --without-tinyxml2
+ else
+ default
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete -o -name '*.a' -delete || die
+}