summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-04-14 12:38:18 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-04-14 12:38:18 +0700
commit2f076d5dc28f9e76e41da902d8ea176b48f53cd5 (patch)
tree99254d13407a77f90719d29c5c15fbe67a92865e /dev-util
parentdev-python/elastic-transport: Stabilize 8.13.0 amd64, #929922 (diff)
downloadgentoo-2f076d5dc28f9e76e41da902d8ea176b48f53cd5.tar.gz
gentoo-2f076d5dc28f9e76e41da902d8ea176b48f53cd5.tar.bz2
gentoo-2f076d5dc28f9e76e41da902d8ea176b48f53cd5.zip
dev-util/diffuse: bump to 0.9.0
Closes: https://bugs.gentoo.org/929535 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/diffuse/Manifest1
-rw-r--r--dev-util/diffuse/diffuse-0.9.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/diffuse/Manifest b/dev-util/diffuse/Manifest
index 45671f2e8adc..5e8acb655b95 100644
--- a/dev-util/diffuse/Manifest
+++ b/dev-util/diffuse/Manifest
@@ -1 +1,2 @@
DIST diffuse-0.8.2.tar.gz 1187378 BLAKE2B 466cb2291dcc812a82ade4fb59c3e3faf1f632d741fc3efef886c00b100e8edebdddc1837e980d9bb86c18182172cf9afca3b1abc17a8258669f6aada0763beb SHA512 c2a5c1cac435bc0879fc6e6f10bcf10bd8e58e4a2cb603a4e1435c411b3d66373424680d1a41296d38c249e659aa53e67c8783eb26a3d02a42ef5c7e7fa1e245
+DIST diffuse-0.9.0.tar.gz 1193105 BLAKE2B 934d38722e0bd9f83a915c681521c1699e0a2efefdcbbb3e23c3f9635467fb31d9f364a72b0e7c78ca65bf9fe154e5ebbeecdbfe1a4b412149a3b0f3a511d6e9 SHA512 9a9ed6047531eaf80fed867bc2feba081f183ee7e5e5c940b0cb912af6d17c7c22df48b7aa76c3f17d4fafeff1bade45216d26ef689fef33b3680bdc70ed80ac
diff --git a/dev-util/diffuse/diffuse-0.9.0.ebuild b/dev-util/diffuse/diffuse-0.9.0.ebuild
new file mode 100644
index 000000000000..0c1ca8533aac
--- /dev/null
+++ b/dev-util/diffuse/diffuse-0.9.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..12} )
+PLOCALES="cs de es fr it ja ka ko nl pl pt pt_BR ru sv th tr zh_CN zh_TW"
+inherit meson plocale python-r1 xdg
+
+DESCRIPTION="A graphical tool to compare and merge text files"
+HOMEPAGE="http://diffuse.sourceforge.net/ https://github.com/MightyCreak/diffuse/"
+SRC_URI="https://github.com/MightyCreak/diffuse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ ')
+ x11-libs/gtk+:3[introspection]
+ !sci-chemistry/tinker"
+# file collision, bug #279018
+
+src_prepare() {
+ default
+ plocale_find_changes po '' '.po'
+
+ rm_locale() {
+ rm -f po/${1}.po
+ rm -rf data/usr/share/man/${1}
+ rm -rf data/usr/share/gnome/help/${PN}/$1
+ rm -f data/usr/share/omf/${PN}/${PN}-$1.omf
+ sed -e "/^${1}/d" -i po/LINGUAS
+ }
+
+ plocale_for_each_disabled_locale rm_locale
+}
+
+src_install() {
+ meson_src_install
+ rm "${D}"/usr/bin/${PN} || die "rm ${PN} failed"
+ python_foreach_impl python_doscript ../${P}-build/src/${PN}/${PN}
+ mkdir "${D}"/usr/share/metainfo || die "mkdir metainfo failed"
+ mv "${D}"/usr/share/appdata/* "${D}"/usr/share/metainfo/ \
+ || die "mv appdata -> metainfo failed"
+ dodoc AUTHORS CHANGELOG.md README.md
+}