summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-09 15:04:57 +0000
committerSam James <sam@gentoo.org>2021-01-09 15:05:16 +0000
commit33deaff0f1b1141fee98c51ad5f6805512eace4d (patch)
tree1f4bda82bcdb0f2b3f68bf2a1d381430367cb13d /dev-util
parentdev-libs/libjcat: Bump to version 0.1.5 (diff)
downloadgentoo-33deaff0f1b1141fee98c51ad5f6805512eace4d.tar.gz
gentoo-33deaff0f1b1141fee98c51ad5f6805512eace4d.tar.bz2
gentoo-33deaff0f1b1141fee98c51ad5f6805512eace4d.zip
dev-util/bcpp: bump to 20210108
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bcpp/Manifest1
-rw-r--r--dev-util/bcpp/bcpp-20150811-r1.ebuild2
-rw-r--r--dev-util/bcpp/bcpp-20210108.ebuild34
3 files changed, 36 insertions, 1 deletions
diff --git a/dev-util/bcpp/Manifest b/dev-util/bcpp/Manifest
index 20396938c7bc..c31b8dc2d74e 100644
--- a/dev-util/bcpp/Manifest
+++ b/dev-util/bcpp/Manifest
@@ -1 +1,2 @@
DIST bcpp-20150811.tgz 145969 BLAKE2B c7cdb21b6c07599c93c6f3fdf6ca4f5e825d4ae5f955e1c969d744a9ff2594bf3c7dcded1582dff695201f6e7e8ed57d5796883b63c5c57476c6601da6a49717 SHA512 a11462574bd87cf66dc50ce23f188d335480aae5448b527694791d4b7ae5cde27c0e0c0850dc8899b2b66198c37a434985c833f95f7f2d2d88a3b7dfe4ff34a9
+DIST bcpp-20210108.tgz 150080 BLAKE2B 5614b1e9957d63532ed6ba6d4588ae8b899201c363984bc99726bf48ae49ee9d16a71c407e3988fdeb715fef5e67343bc56c94eb1c8e977a14a6c2b08ee6668a SHA512 46a8fff766bbca4833c898d550ce4f0ac5e6ea64a2e05e63e4680186345a080aa30e54a4a5a3d22d47df8e8c8cbc4e738578fd59ec647d305c32a228d3b01e73
diff --git a/dev-util/bcpp/bcpp-20150811-r1.ebuild b/dev-util/bcpp/bcpp-20150811-r1.ebuild
index e3784862399d..bf4a9d304e7a 100644
--- a/dev-util/bcpp/bcpp-20150811-r1.ebuild
+++ b/dev-util/bcpp/bcpp-20150811-r1.ebuild
@@ -5,7 +5,7 @@ EAPI="6"
DESCRIPTION="Indents C/C++ source code"
HOMEPAGE="https://invisible-island.net/bcpp/"
-SRC_URI="ftp://invisible-island.net/bcpp/${P}.tgz"
+SRC_URI="ftp://ftp.invisible-island.net/bcpp/${P}.tgz"
LICENSE="MIT"
SLOT="0"
diff --git a/dev-util/bcpp/bcpp-20210108.ebuild b/dev-util/bcpp/bcpp-20210108.ebuild
new file mode 100644
index 000000000000..2ef7dd6cee6c
--- /dev/null
+++ b/dev-util/bcpp/bcpp-20210108.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Indents C/C++ source code"
+HOMEPAGE="https://invisible-island.net/bcpp/"
+SRC_URI="ftp://ftp.invisible-island.net/bcpp/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+src_compile() {
+ emake CPPFLAGS='-DBCPP_CONFIG_DIR=\"/etc/bcpp/\"'
+}
+
+src_install() {
+ default
+ dodoc CHANGES MANIFEST README VERSION txtdocs/hirachy.txt \
+ txtdocs/manual.txt
+
+ insinto /etc/bcpp
+ doins bcpp.cfg indent.cfg
+}
+
+pkg_postinst() {
+ elog "Check the documentation for more information on how to"
+ elog "Run bcpp. Please note that in order to get help for"
+ elog "bcpp, please run bcpp -h and not the command by itself."
+ elog ""
+ elog "Configuration files are at ${EPREFIX}/etc/bcpp."
+ elog "To use them, use the -c option followed by the filename."
+}