summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-22 05:05:19 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-22 05:05:19 +0200
commit90946dd55e9b20159cbd164d6a42d927a524a134 (patch)
treedb8da82f17dadac7c0209f93a199cde9d9725a0e /dev-util
parentdev-python/mako: Bump to 1.3.6 (diff)
downloadgentoo-90946dd55e9b20159cbd164d6a42d927a524a134.tar.gz
gentoo-90946dd55e9b20159cbd164d6a42d927a524a134.tar.bz2
gentoo-90946dd55e9b20159cbd164d6a42d927a524a134.zip
dev-util/stripe-mock: Bump to 0.192.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.192.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 2a768bc732cd..8082bdd5715b 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1,3 +1,4 @@
DIST stripe-mock-0.188.0.tar.gz 1667602 BLAKE2B 0a26afc1865c2123f4aca4dc8231b74eef43972e8c1f43cb2196529c72feaa0143239c7c74ef34dc9a1cb543eec6ee328a96e45ca4515f488d89452dfbecefc7 SHA512 aaf2ed6619383d7eecdf43e93306b8523f4699ba6e0971724e69c1c0921d0c691ab5211a9e5efb642a7e7dd51324aef2996b663b622a1c346da9d80241a476ee
DIST stripe-mock-0.190.0.tar.gz 1749633 BLAKE2B 3d4e186a9c8fe9d0b6dc457c1b8e998b6fa7d7aa039392de7010478f4b20dd98b9b78ea3112d004ef239e65523f1717bda23f45a9935171efd6629fbf8f7b879 SHA512 90fc3bd64e3743b5c347d12c9b73cf0052f6b4db1c29ad4bb019f64ce97bd592c1b5090d25a40d9d29cf7990f96a4429aa39cb9a938adbfa2bdda29c0395fe99
DIST stripe-mock-0.191.0.tar.gz 1769336 BLAKE2B 97511d99e01cda789c9534e2f407e499f4b1e60d86840d113b1dc5cdd5d67c6493dad76ed025b3237efb119415f2d4f03037bb6d651d089c9092e340d56bd8a2 SHA512 5347b5f5936f6431a0ad90908689a2bbabfa138cf693a52fc4b67f9679fe75f1b9b4ee898b1c70de9e19cb94070bb62bfec4766c7c44960514dc950e9e6f8707
+DIST stripe-mock-0.192.0.tar.gz 1783633 BLAKE2B a5edad1e8924c6a0b72538eb5c4eb91e6b976464352ae3097163e56ab507031d139ad8d205a0ca689c88d1b8f39c2c60daf284592e4c7b4d192b531b2097347a SHA512 d5a289d379fcaa84e3416ed1d27202a6c9a268a7799dba6d8790398f89fd7fa70bd1bf416c21c117ba5312b8ba095d78ddc88ee67bed76c05790b25d84d0ed07
diff --git a/dev-util/stripe-mock/stripe-mock-0.192.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.192.0.ebuild
new file mode 100644
index 000000000000..352d14e2ce00
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.192.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}