summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-25 08:50:24 +0000
committerSam James <sam@gentoo.org>2023-11-25 08:50:52 +0000
commit9d62783d0430b11c2754cc7115d834741d3a20f5 (patch)
treef896be88d2a8e0090a4c7e4205970aa8259a1f06 /dev-util
parentapp-crypt/sequoia-sqv: crank LLVM_MAX_SLOT to 17 (diff)
downloadgentoo-9d62783d0430b11c2754cc7115d834741d3a20f5.tar.gz
gentoo-9d62783d0430b11c2754cc7115d834741d3a20f5.tar.bz2
gentoo-9d62783d0430b11c2754cc7115d834741d3a20f5.zip
dev-util/ccls: crank LLVM_MAX_SLOT to 17
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ccls/ccls-0.20230717-r1.ebuild43
-rw-r--r--dev-util/ccls/ccls-9999.ebuild9
2 files changed, 46 insertions, 6 deletions
diff --git a/dev-util/ccls/ccls-0.20230717-r1.ebuild b/dev-util/ccls/ccls-0.20230717-r1.ebuild
new file mode 100644
index 000000000000..ee7cfb7a7cf5
--- /dev/null
+++ b/dev-util/ccls/ccls-0.20230717-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ LLVM_MAX_SLOT=17
+else
+ LLVM_MAX_SLOT=17
+fi
+
+inherit cmake llvm ${GIT_ECLASS}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} != *9999 ]] ; then
+ SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+# We only depend on Clang because of a quirk in how dependencies work
+# See comment in llvm.eclass docs
+DEPEND="
+ dev-libs/rapidjson
+ <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCCLS_VERSION=${PV}
+ -DUSE_SYSTEM_RAPIDJSON=ON
+ -DCLANG_LINK_CLANG_DYLIB=1
+ )
+ cmake_src_configure
+}
diff --git a/dev-util/ccls/ccls-9999.ebuild b/dev-util/ccls/ccls-9999.ebuild
index c6b39f910fd1..ee7cfb7a7cf5 100644
--- a/dev-util/ccls/ccls-9999.ebuild
+++ b/dev-util/ccls/ccls-9999.ebuild
@@ -7,9 +7,9 @@ EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
- LLVM_MAX_SLOT=16
+ LLVM_MAX_SLOT=17
else
- LLVM_MAX_SLOT=16
+ LLVM_MAX_SLOT=17
fi
inherit cmake llvm ${GIT_ECLASS}
@@ -17,16 +17,13 @@ inherit cmake llvm ${GIT_ECLASS}
DESCRIPTION="C/C++/ObjC language server"
HOMEPAGE="https://github.com/MaskRay/ccls"
-if [[ ${PV} == *9999 ]] ; then
- SRC_URI=""
-else
+if [[ ${PV} != *9999 ]] ; then
SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~riscv"
fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
# We only depend on Clang because of a quirk in how dependencies work
# See comment in llvm.eclass docs