summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2023-03-07 13:58:34 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2023-03-07 15:50:24 -0700
commitae0a858bfeb6d7ccd812814dd55ef8c04bbd44bb (patch)
tree93599c9e2233ebbf571333c701c9cb9025bb7052 /dev-util
parentdev-python/greenlet: Remove old (diff)
downloadgentoo-ae0a858bfeb6d7ccd812814dd55ef8c04bbd44bb.tar.gz
gentoo-ae0a858bfeb6d7ccd812814dd55ef8c04bbd44bb.tar.bz2
gentoo-ae0a858bfeb6d7ccd812814dd55ef8c04bbd44bb.zip
dev-util/ebuildtester: Add Python 3.11
Closes: https://bugs.gentoo.org/896926 Closes: https://github.com/gentoo/gentoo/pull/29983 Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ebuildtester/ebuildtester-42-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/ebuildtester/ebuildtester-42-r1.ebuild b/dev-util/ebuildtester/ebuildtester-42-r1.ebuild
new file mode 100644
index 000000000000..ad28fc1c3ead
--- /dev/null
+++ b/dev-util/ebuildtester/ebuildtester-42-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9,10,11} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="A dockerized approach to test a Gentoo package within a clean stage3 container"
+HOMEPAGE="https://ebuildtester.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-containers/docker
+ sys-fs/fuse
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp "${PN}.bash-completion" "${PN}"
+}