summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2024-05-11 02:16:49 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-06-08 15:30:41 +0300
commitc763fa2da5af460e1cab02d1bf622d1e47fd2b5e (patch)
tree3d2da593068cc2bf48d6354974344810762010c1 /dev-util
parentdev-util/codeblocks: dev preview 20.03_p13518 (2024-05-05) bump (diff)
downloadgentoo-c763fa2da5af460e1cab02d1bf622d1e47fd2b5e.tar.gz
gentoo-c763fa2da5af460e1cab02d1bf622d1e47fd2b5e.tar.bz2
gentoo-c763fa2da5af460e1cab02d1bf622d1e47fd2b5e.zip
dev-util/codeblocks: update live ebuild (fix USE="contib" race cond.)
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/36447 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/codeblocks/codeblocks-9999.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-util/codeblocks/codeblocks-9999.ebuild b/dev-util/codeblocks/codeblocks-9999.ebuild
index 531794a90f95..25b3ef48c800 100644
--- a/dev-util/codeblocks/codeblocks-9999.ebuild
+++ b/dev-util/codeblocks/codeblocks-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
WX_GTK_VER="3.2-gtk3"
-inherit autotools flag-o-matic subversion wxwidgets xdg
+inherit autotools flag-o-matic multiprocessing subversion wxwidgets xdg
DESCRIPTION="The open source, cross platform, free C, C++ and Fortran IDE"
HOMEPAGE="https://codeblocks.org/"
@@ -69,6 +69,18 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_compile() {
+ if use contrib; then
+ if (( $(get_makeopts_jobs) > 8 )); then
+ emake -j8 # Bug 930819
+ else
+ emake
+ fi
+ else
+ emake
+ fi
+}
+
src_install() {
default
find "${ED}" -type f -name '*.la' -delete || die