summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-12-21 12:44:15 -0500
committerMatt Turner <mattst88@gentoo.org>2020-12-27 14:18:55 -0500
commitef2406cd3f9b10da3162af898f287b3883730564 (patch)
treebc06f622a236fa1655495da48cbbe82e8acbb31d /dev-util
parentdev-util/pkgconfig: drop misleading comment (diff)
downloadgentoo-ef2406cd3f9b10da3162af898f287b3883730564.tar.gz
gentoo-ef2406cd3f9b10da3162af898f287b3883730564.tar.bz2
gentoo-ef2406cd3f9b10da3162af898f287b3883730564.zip
dev-util/wayland-scanner: Add new package
Closes: https://bugs.gentoo.org/576146 Closes: https://bugs.gentoo.org/759133 Signed-off-by: Matt Turner <mattst88@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/18751 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/wayland-scanner/Manifest1
-rw-r--r--dev-util/wayland-scanner/metadata.xml8
-rw-r--r--dev-util/wayland-scanner/wayland-scanner-1.18.91.ebuild49
-rw-r--r--dev-util/wayland-scanner/wayland-scanner-9999.ebuild49
4 files changed, 107 insertions, 0 deletions
diff --git a/dev-util/wayland-scanner/Manifest b/dev-util/wayland-scanner/Manifest
new file mode 100644
index 000000000000..8abe868d035a
--- /dev/null
+++ b/dev-util/wayland-scanner/Manifest
@@ -0,0 +1 @@
+DIST wayland-1.18.91.tar.xz 453500 BLAKE2B 6e234fa637bf4329fcf37c7372e3d02a50742812e2f61477ce302da4c2a1b9377874b0e4e2da899c726ede417081c4d459e40863169352825dd38a8fe0dcf267 SHA512 5ab770c87507e8248aa5197a253f27f3cca984bf1a69c52b438e9aaf512e6b0d841321f81c20643a49ef62eeb6c8b3a6391eadfee5c8822c3cf0d63bb0a8e0f8
diff --git a/dev-util/wayland-scanner/metadata.xml b/dev-util/wayland-scanner/metadata.xml
new file mode 100644
index 000000000000..e943b72b8a48
--- /dev/null
+++ b/dev-util/wayland-scanner/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-util/wayland-scanner/wayland-scanner-1.18.91.ebuild b/dev-util/wayland-scanner/wayland-scanner-1.18.91.ebuild
new file mode 100644
index 000000000000..eeb424d9d3c1
--- /dev/null
+++ b/dev-util/wayland-scanner/wayland-scanner-1.18.91.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
+ inherit git-r3
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/wayland-${PV}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ S="${WORKDIR}/wayland-${PV}"
+fi
+inherit meson multilib-minimal
+
+DESCRIPTION="wayland-scanner tool"
+HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ !<dev-libs/wayland-${PV}
+ >=dev-libs/expat-2.1.0-r3:=[$MULTILIB_USEDEP]
+"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddocumentation=false
+ -Ddtd_validation=false
+ -Dlibraries=false
+ -Dscanner=true
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}
diff --git a/dev-util/wayland-scanner/wayland-scanner-9999.ebuild b/dev-util/wayland-scanner/wayland-scanner-9999.ebuild
new file mode 100644
index 000000000000..eeb424d9d3c1
--- /dev/null
+++ b/dev-util/wayland-scanner/wayland-scanner-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
+ inherit git-r3
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/wayland-${PV}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ S="${WORKDIR}/wayland-${PV}"
+fi
+inherit meson multilib-minimal
+
+DESCRIPTION="wayland-scanner tool"
+HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ !<dev-libs/wayland-${PV}
+ >=dev-libs/expat-2.1.0-r3:=[$MULTILIB_USEDEP]
+"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddocumentation=false
+ -Ddtd_validation=false
+ -Dlibraries=false
+ -Dscanner=true
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}