summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-03-22 11:06:16 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-22 11:06:16 +0100
commitcb797361214a6547228ddb23a5c046e14a9fdbe5 (patch)
treec5bd143272ee82db5d2596b0cd9b7254da77d1ca /dev-vcs/git/git-2.28.1.ebuild
parentdev-python/flit_core: Add python@ as co-maint (diff)
downloadgentoo-cb797361214a6547228ddb23a5c046e14a9fdbe5.tar.gz
gentoo-cb797361214a6547228ddb23a5c046e14a9fdbe5.tar.bz2
gentoo-cb797361214a6547228ddb23a5c046e14a9fdbe5.zip
dev-vcs/git: respect toolchain variables with USE=gnome-keyring
Closes: https://bugs.gentoo.org/762796 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-vcs/git/git-2.28.1.ebuild')
-rw-r--r--dev-vcs/git/git-2.28.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-vcs/git/git-2.28.1.ebuild b/dev-vcs/git/git-2.28.1.ebuild
index d725b8e79c39..b52504ad1b28 100644
--- a/dev-vcs/git/git-2.28.1.ebuild
+++ b/dev-vcs/git/git-2.28.1.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -113,6 +116,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -372,7 +376,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi