summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-01 21:07:08 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-01 21:07:08 +0100
commit5f9b5127aeb130dd1f1baff7fef1ef8db186e49b (patch)
tree3ea5c85c88d9e1c3ffcb8936ab4a6a45d238f48c /dev-vcs/git
parentdev-perl/Ace: remove uclibc (diff)
downloadgentoo-5f9b5127aeb130dd1f1baff7fef1ef8db186e49b.tar.gz
gentoo-5f9b5127aeb130dd1f1baff7fef1ef8db186e49b.tar.bz2
gentoo-5f9b5127aeb130dd1f1baff7fef1ef8db186e49b.zip
dev-vcs/git: remove uclibc
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/git-2.32.0-r1.ebuild9
-rw-r--r--dev-vcs/git/git-2.33.1.ebuild9
-rw-r--r--dev-vcs/git/git-2.34.1-r1.ebuild9
-rw-r--r--dev-vcs/git/git-2.34.1.ebuild9
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild9
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild9
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild9
-rw-r--r--dev-vcs/git/git-9999.ebuild9
8 files changed, 8 insertions, 64 deletions
diff --git a/dev-vcs/git/git-2.32.0-r1.ebuild b/dev-vcs/git/git-2.32.0-r1.ebuild
index 50b3cfccc709..6c3d422fd38b 100644
--- a/dev-vcs/git/git-2.32.0-r1.ebuild
+++ b/dev-vcs/git/git-2.32.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -226,13 +226,6 @@ exportmakeopts() {
myopts+=( ASCIIDOC8=YesPlease )
fi
- # Bug 290465:
- # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- if [[ "${CHOST}" == *-uclibc* ]] ; then
- myopts+=( NO_NSEC=YesPlease )
- use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
- fi
-
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
}
diff --git a/dev-vcs/git/git-2.33.1.ebuild b/dev-vcs/git/git-2.33.1.ebuild
index a8aad528c221..26673133f9f9 100644
--- a/dev-vcs/git/git-2.33.1.ebuild
+++ b/dev-vcs/git/git-2.33.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -222,13 +222,6 @@ exportmakeopts() {
myopts+=( ASCIIDOC8=YesPlease )
fi
- # Bug 290465:
- # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- if [[ "${CHOST}" == *-uclibc* ]] ; then
- myopts+=( NO_NSEC=YesPlease )
- use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
- fi
-
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
}
diff --git a/dev-vcs/git/git-2.34.1-r1.ebuild b/dev-vcs/git/git-2.34.1-r1.ebuild
index 74e58d7f357a..c77551019c67 100644
--- a/dev-vcs/git/git-2.34.1-r1.ebuild
+++ b/dev-vcs/git/git-2.34.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -222,13 +222,6 @@ exportmakeopts() {
myopts+=( ASCIIDOC8=YesPlease )
fi
- # Bug 290465:
- # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- if [[ "${CHOST}" == *-uclibc* ]] ; then
- myopts+=( NO_NSEC=YesPlease )
- use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
- fi
-
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
}
diff --git a/dev-vcs/git/git-2.34.1.ebuild b/dev-vcs/git/git-2.34.1.ebuild
index c1890e3e5aad..30f56796419f 100644
--- a/dev-vcs/git/git-2.34.1.ebuild
+++ b/dev-vcs/git/git-2.34.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -222,13 +222,6 @@ exportmakeopts() {
myopts+=( ASCIIDOC8=YesPlease )
fi
- # Bug 290465:
- # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- if [[ "${CHOST}" == *-uclibc* ]] ; then
- myopts+=( NO_NSEC=YesPlease )
- use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
- fi
-
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
}
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 74e58d7f357a..c77551019c67 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -222,13 +222,6 @@ exportmakeopts() {
myopts+=( ASCIIDOC8=YesPlease )
fi
- # Bug 290465:
- # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- if [[ "${CHOST}" == *-uclibc* ]] ; then
- myopts+=( NO_NSEC=YesPlease )
- use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
- fi
-
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
}
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 74e58d7f357a..c77551019c67 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -222,13 +222,6 @@ exportmakeopts() {
myopts+=( ASCIIDOC8=YesPlease )
fi
- # Bug 290465:
- # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- if [[ "${CHOST}" == *-uclibc* ]] ; then
- myopts+=( NO_NSEC=YesPlease )
- use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
- fi
-
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
}
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 74e58d7f357a..c77551019c67 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -222,13 +222,6 @@ exportmakeopts() {
myopts+=( ASCIIDOC8=YesPlease )
fi
- # Bug 290465:
- # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- if [[ "${CHOST}" == *-uclibc* ]] ; then
- myopts+=( NO_NSEC=YesPlease )
- use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
- fi
-
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
}
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 74e58d7f357a..c77551019c67 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -222,13 +222,6 @@ exportmakeopts() {
myopts+=( ASCIIDOC8=YesPlease )
fi
- # Bug 290465:
- # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- if [[ "${CHOST}" == *-uclibc* ]] ; then
- myopts+=( NO_NSEC=YesPlease )
- use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
- fi
-
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
}