summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-11-20 11:54:59 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2015-11-20 11:55:17 -0800
commit9eee3a075eeaca03f24260ea632643e418095dc3 (patch)
treea9f6b954e2e77ee2cc23f37cdf32c9bda8ca7c62 /dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild
parentapp-text/groonga-normalizer-mysql: Version bump (diff)
downloadgentoo-9eee3a075eeaca03f24260ea632643e418095dc3.tar.gz
gentoo-9eee3a075eeaca03f24260ea632643e418095dc3.tar.bz2
gentoo-9eee3a075eeaca03f24260ea632643e418095dc3.zip
dev-vcs/notify-webhook: Bump. Upstream now has release tags.
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild')
-rw-r--r--dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild b/dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild
new file mode 100644
index 000000000000..8441e7fad76e
--- /dev/null
+++ b/dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4,5} pypy3 )
+
+DESCRIPTION="Git post-receive web hook notifier in Python."
+HOMEPAGE="https://github.com/metajack/notify-webhook"
+#COMMIT='c571160f155122446e97bb01c1150b4d14ea69d6'
+SRC_URI="https://github.com/metajack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/simplejson"
+RDEPEND="${DEPEND}"
+
+#MY_P="${PN}-${COMMIT}"
+#S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc *markdown
+ exeinto /usr/libexec/githook/$PN/
+ doexe notify-webhook.py
+}