summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-07-03 22:22:37 -0400
committerAaron Bauman <bman@gentoo.org>2020-07-03 22:24:06 -0400
commit17ed872c6334185fdebf3d60b2aa219fc1fe7516 (patch)
tree12e8c60e602df8f5c29d00e701eab0a16ede9847 /dev-vcs
parentmedia-plugins/kodi-pvr-nextpvr: 3.3.21 version bump (diff)
downloadgentoo-17ed872c6334185fdebf3d60b2aa219fc1fe7516.tar.gz
gentoo-17ed872c6334185fdebf3d60b2aa219fc1fe7516.tar.bz2
gentoo-17ed872c6334185fdebf3d60b2aa219fc1fe7516.zip
*/*: drop last-rited py2 packages
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-deps/git-deps-9999.ebuild49
-rw-r--r--dev-vcs/git-deps/metadata.xml15
-rw-r--r--dev-vcs/git-remote-hg/Manifest1
-rw-r--r--dev-vcs/git-remote-hg/git-remote-hg-1.0.1.ebuild40
-rw-r--r--dev-vcs/git-remote-hg/metadata.xml20
5 files changed, 0 insertions, 125 deletions
diff --git a/dev-vcs/git-deps/git-deps-9999.ebuild b/dev-vcs/git-deps/git-deps-9999.ebuild
deleted file mode 100644
index 57d46ddb9f56..000000000000
--- a/dev-vcs/git-deps/git-deps-9999.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGIT_REPO_URI="https://github.com/aspiers/git-deps"
-EGIT_BRANCH=master
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils git-r3 python-single-r1
-
-DESCRIPTION="git commit dependency analysis tool"
-HOMEPAGE="https://github.com/aspiers/git-deps"
-
-LICENSE="GPL-2"
-SLOT="0"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/flask[${PYTHON_MULTI_USEDEP}]
- dev-python/pygit2[${PYTHON_MULTI_USEDEP}]
- ')
- net-libs/nodejs
- ${PYTHON_DEPS}
- "
-DEPEND="${RDEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-HTML_DOCS="html/."
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_install() {
- python_newscript git-deps.py git-deps
- einstalldocs
-}
-
-pkg_postinst() {
- elog "Notes regarding the '--serve' option:"
- elog "Please run 'npm install browserify' once"
- elog "Copy the html sources:"
- elog "rsync -av ${EROOT}/usr/share/${PN}/html ~/git-deps-html"
- elog "cd ~/git-deps-html"
- elog "npm install"
- elog "browserify -t coffeeify -d js/git-deps-graph.coffee -o js/bundle.js"
-}
diff --git a/dev-vcs/git-deps/metadata.xml b/dev-vcs/git-deps/metadata.xml
deleted file mode 100644
index 1a9f54bc290b..000000000000
--- a/dev-vcs/git-deps/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>nicolasbock@gentoo.org</email>
- <name>Nicolas Bock</name>
- </maintainer>
- <longdescription lang="en">
- git-deps is a tool for performing automatic analysis of dependencies
- between commits in a git repository.
- </longdescription>
- <upstream>
- <remote-id type="github">aspiers/git-deps</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-vcs/git-remote-hg/Manifest b/dev-vcs/git-remote-hg/Manifest
deleted file mode 100644
index 6e1d26b61663..000000000000
--- a/dev-vcs/git-remote-hg/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST git-remote-hg-1.0.1.tar.gz 57856 BLAKE2B 635073fbd0d9fe0ebbc2e9b5e49298bdb9f6b02f964219271a4bd930746e892e58fabde2afa94e998e4bd4aede91d9ac80291eef1bd3eb16cf82f6691514259b SHA512 b665cb6dc0564dc7f2cacade9000378f895b77a3186e091b841e58ddef37834e3cc87e81a76ab713997c6f837a768eff91d6b8a156c6277da0e34a2f156a5290
diff --git a/dev-vcs/git-remote-hg/git-remote-hg-1.0.1.ebuild b/dev-vcs/git-remote-hg/git-remote-hg-1.0.1.ebuild
deleted file mode 100644
index 6351daeb396a..000000000000
--- a/dev-vcs/git-remote-hg/git-remote-hg-1.0.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Semi-official Mercurial bridge from Git project"
-HOMEPAGE="https://github.com/mnauw/git-remote-hg"
-SRC_URI="https://github.com/mnauw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="
- app-text/asciidoc
-"
-RDEPEND="
- dev-vcs/git
- dev-vcs/mercurial
-"
-
-# Some tests fail.
-RESTRICT="test"
-
-src_compile() {
- distutils-r1_src_compile
- emake doc
-}
-
-src_install() {
- distutils-r1_src_install
- emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install-doc
-}
-
-src_test() {
- default
-}
diff --git a/dev-vcs/git-remote-hg/metadata.xml b/dev-vcs/git-remote-hg/metadata.xml
deleted file mode 100644
index 516b1c49f64f..000000000000
--- a/dev-vcs/git-remote-hg/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>realnc@gmail.com</email>
- <name>Nikos Chantziaras</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <longdescription>
- 'git-remote-hg' is the semi-official Mercurial bridge from Git project,
- once installed, it allows you to clone, fetch and push to and from
- Mercurial repositories as if they were Git ones.
- </longdescription>
- <upstream>
- <remote-id type="github">mnauw/git-remote-hg</remote-id>
- </upstream>
-</pkgmetadata>