summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-03 03:20:23 +0100
committerSam James <sam@gentoo.org>2023-06-10 11:24:05 +0100
commit60252448ea396117671e3c7acceee7ba60673c73 (patch)
tree692ffdaa5a41f2e780e0ca3a113910d9b7d880e7 /eclass/xorg-3.eclass
parentusr-ldscript.eclass: drop dead prefix targets (diff)
downloadgentoo-60252448ea396117671e3c7acceee7ba60673c73.tar.gz
gentoo-60252448ea396117671e3c7acceee7ba60673c73.tar.bz2
gentoo-60252448ea396117671e3c7acceee7ba60673c73.zip
xorg-3.eclass: drop dead prefix targets
Followup to 3db70e9c014e415ae38a713b47cf7b299fd11945. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'eclass/xorg-3.eclass')
-rw-r--r--eclass/xorg-3.eclass17
1 files changed, 1 insertions, 16 deletions
diff --git a/eclass/xorg-3.eclass b/eclass/xorg-3.eclass
index c3ece64ae42d..74ba29657e64 100644
--- a/eclass/xorg-3.eclass
+++ b/eclass/xorg-3.eclass
@@ -273,19 +273,7 @@ xorg-3_src_unpack() {
xorg-3_reconf_source() {
debug-print-function ${FUNCNAME} "$@"
- case ${CHOST} in
- *-aix* | *-winnt*)
- # some hosts need full eautoreconf
- [[ -e "./configure.ac" || -e "./configure.in" ]] \
- && XORG_EAUTORECONF=yes
- ;;
- *)
- # elibtoolize required for BSD
- [[ ${XORG_EAUTORECONF} != no && ( -e "./configure.ac" || -e "./configure.in" ) ]] \
- && XORG_EAUTORECONF=yes
- ;;
- esac
-
+ [[ ${XORG_EAUTORECONF} != no && ( -e "./configure.ac" || -e "./configure.in" ) ]] && XORG_EAUTORECONF=yes
[[ ${XORG_EAUTORECONF} != no ]] && eautoreconf
elibtoolize --patch-only
}
@@ -326,9 +314,6 @@ xorg-3_font_configure() {
xorg-3_flags_setup() {
debug-print-function ${FUNCNAME} "$@"
- # Win32 require special define
- [[ ${CHOST} == *-winnt* ]] && append-cppflags -DWIN32 -D__STDC__
-
# Hardened flags break module autoloading et al (also fixes #778494)
if [[ ${PN} == xorg-server || ${PN} == xf86-video-* || ${PN} == xf86-input-* ]]; then
filter-flags -fno-plt