summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-12-25 09:29:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-25 16:47:33 +0100
commit7d9c4d95eb340cfc80232665f8ed85c3f8c11bb2 (patch)
treee1d75cafdd8367606ab772d86f55419a5b287d90 /eclass
parentkernel-install.eclass: Add kernel-install_compress_modules (diff)
downloadgentoo-7d9c4d95eb340cfc80232665f8ed85c3f8c11bb2.tar.gz
gentoo-7d9c4d95eb340cfc80232665f8ed85c3f8c11bb2.tar.bz2
gentoo-7d9c4d95eb340cfc80232665f8ed85c3f8c11bb2.zip
kernel-{build,install}.eclass: drop plymouth for generic-uki
plymouth pulls in drm, and drm includes all gpu drivers and their firmware especially the firmware files are very big. The whole thing costs us 15M on each initrd, and therefore gpkg. Also exclude the netronome drivers, these also have ridiculously large firmware files. Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kernel-build.eclass8
-rw-r--r--eclass/kernel-install.eclass8
2 files changed, 8 insertions, 8 deletions
diff --git a/eclass/kernel-build.eclass b/eclass/kernel-build.eclass
index 69a2689601fa..29ee9f86e7e2 100644
--- a/eclass/kernel-build.eclass
+++ b/eclass/kernel-build.eclass
@@ -395,10 +395,10 @@ kernel-build_src_install() {
local dracut_modules=(
base bash btrfs cifs crypt crypt-gpg crypt-loop dbus dbus-daemon
- dm dmraid drm dracut-systemd fido2 i18n fs-lib kernel-modules
+ dm dmraid dracut-systemd fido2 i18n fs-lib kernel-modules
kernel-network-modules kernel-modules-extra lunmask lvm nbd
mdraid modsign network network-manager nfs nvdimm nvmf pcsc
- pkcs11 plymouth qemu qemu-net resume rngd rootfs-block shutdown
+ pkcs11 qemu qemu-net resume rngd rootfs-block shutdown
systemd systemd-ac-power systemd-ask-password systemd-initrd
systemd-integritysetup systemd-pcrphase systemd-sysusers
systemd-udevd systemd-veritysetup terminfo tpm2-tss udev-rules
@@ -423,6 +423,8 @@ kernel-build_src_install() {
--reproducible
--ro-mnt
--modules "${dracut_modules[*]}"
+ # Pulls in huge firmware files
+ --omit-drivers "nfp"
)
# Tries to update ld cache
@@ -433,7 +435,7 @@ kernel-build_src_install() {
local ukify_args=(
--linux="${image}"
--initrd="${image%/*}/initrd"
- --cmdline="root=/dev/gpt-auto-root ro quiet splash"
+ --cmdline="root=/dev/gpt-auto-root ro"
--uname="${dir_ver}"
--output="${image%/*}/uki.efi"
)
diff --git a/eclass/kernel-install.eclass b/eclass/kernel-install.eclass
index 1cbb7d54d3de..8c4d5c14fc03 100644
--- a/eclass/kernel-install.eclass
+++ b/eclass/kernel-install.eclass
@@ -127,7 +127,6 @@ if [[ ${KERNEL_IUSE_GENERIC_UKI} ]]; then
["dev-libs/openssl"]="Apache-2.0"
["dev-libs/userspace-rcu"]="LGPL-2.1"
["media-libs/libmtp"]="LGPL-2.1"
- ["media-libs/libpng"]="libpng2"
["media-libs/libv4l"]="LGPL-2.1+"
["net-dns/c-ares"]="MIT ISC"
["net-dns/libidn2"]="|| ( GPL-2+ LGPL-3+ ) GPL-3+ unicode"
@@ -159,15 +158,12 @@ if [[ ${KERNEL_IUSE_GENERIC_UKI} ]]; then
["sys-apps/nvme-cli"]="GPL-2 GPL-2+"
["sys-apps/pcsc-lite"]="BSD ISC MIT GPL-3+ GPL-2"
["sys-apps/rng-tools"]="GPL-2"
- ["sys-apps/sandbox"]="GPL-2"
["sys-apps/sed"]="GPL-3+"
["sys-apps/shadow"]="BSD GPL-2"
["sys-apps/systemd[boot(-),cryptsetup,pkcs11,policykit,tpm,ukify(-)]"]="GPL-2 LGPL-2.1 MIT public-domain"
["sys-apps/util-linux"]="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
["sys-auth/polkit"]="LGPL-2"
["sys-block/nbd"]="GPL-2"
- ["sys-block/open-isns"]="LGPL-2.1"
- ["sys-boot/plymouth"]="GPL-2"
["sys-devel/gcc"]="GPL-3+ LGPL-3+ || ( GPL-3+ libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.3+"
["sys-fs/btrfs-progs"]="GPL-2"
["sys-fs/cryptsetup"]="GPL-2+"
@@ -192,7 +188,6 @@ if [[ ${KERNEL_IUSE_GENERIC_UKI} ]]; then
["sys-libs/readline"]="GPL-3+"
["sys-libs/zlib"]="ZLIB"
["sys-process/procps"]="GPL-2+ LGPL-2+ LGPL-2.1+"
- ["x11-libs/libdrm"]="MIT"
["amd64? ( sys-firmware/intel-microcode )"]="amd64? ( intel-ucode )"
["x86? ( sys-firmware/intel-microcode )"]="x86? ( intel-ucode )"
)
@@ -772,10 +767,13 @@ kernel-install_compress_modules() {
debug-print-function ${FUNCNAME} "${@}"
if use module-compress; then
+ einfo "Compressing kernel modules ..."
# taken from scripts/Makefile.modinst
find "${ED}/lib" -name '*.ko' -exec \
xz --check=crc32 --lzma2=dict=1MiB {} + || die
fi
+}
+
fi
EXPORT_FUNCTIONS src_test pkg_preinst pkg_postinst pkg_prerm pkg_postrm