summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/cs2d/cs2d-0127.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/cs2d/cs2d-0127.ebuild')
-rw-r--r--games-action/cs2d/cs2d-0127.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/games-action/cs2d/cs2d-0127.ebuild b/games-action/cs2d/cs2d-0127.ebuild
new file mode 100644
index 000000000000..34eb6bce4f99
--- /dev/null
+++ b/games-action/cs2d/cs2d-0127.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Counter-Strike 2D is freeware clone of Counter-Strike with some added features in gameplay"
+HOMEPAGE="http://www.cs2d.com/"
+SRC_URI="http://dev.gentoo.org/~maksbotan/cs2d/cs2d_${PV}_linux.zip
+ http://dev.gentoo.org/~maksbotan/cs2d/cs2d_${PV}_win.zip
+ http://dev.gentoo.org/~maksbotan/cs2d/cs2d.png"
+LICENSE="freedist"
+
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ x86? (
+ media-libs/openal
+ media-libs/freetype:2
+ x11-libs/libX11
+ x11-libs/libXxf86vm
+ virtual/opengl
+ )
+ amd64? (
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=media-libs/freetype-2.5.0.1:2[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXxf86vm-1.1.3[abi_x86_32(-)]
+ )"
+
+QA_PREBUILT="opt/cs2d/CounterStrike2D"
+
+S=${WORKDIR}
+
+src_prepare() {
+ # removing windows files
+ rm -f *.exe *.bat || die
+
+ # OpenAL is default sound driver
+ sed -i \
+ -e 's:^sounddriver.*$:sounddriver OpenAL Default:' \
+ sys/config.cfg || die
+}
+
+src_install() {
+ insinto "${GAMES_PREFIX_OPT}"/${PN}
+ doins -r .
+ # avoid file collision with untracked file
+ rm -f "${ED%/}/${GAMES_PREFIX_OPT}"/${PN}/sys/core/started.cfg
+
+ make_desktop_entry CounterStrike2D "Counter Strike 2D"
+ make_desktop_entry "CounterStrike2D -fullscreen -24bit" "Counter Strike 2D - FULLSCREEN"
+ games_make_wrapper CounterStrike2D ./CounterStrike2D \
+ "${GAMES_PREFIX_OPT}"/${PN} "${GAMES_PREFIX_OPT}"/${PN}
+
+ doicon "${DISTDIR}"/${PN}.png
+
+ prepgamesdirs
+
+ # fixing permissions
+ fperms -R g+w "${GAMES_PREFIX_OPT}"/${PN}/maps
+ fperms -R g+w "${GAMES_PREFIX_OPT}"/${PN}/screens
+ fperms -R g+w "${GAMES_PREFIX_OPT}"/${PN}/sys
+ fperms ug+x "${GAMES_PREFIX_OPT}"/${PN}/CounterStrike2D
+}