summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-17 13:09:55 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-17 19:38:26 -0500
commit8b2cf53dc7076ebc0be5529d72da832e15989470 (patch)
tree8180ba38e1949467087643f5cd51d3730f411a69 /games-action/openclonk/files
parentclean old (diff)
downloadgentoo-8b2cf53dc7076ebc0be5529d72da832e15989470.tar.gz
gentoo-8b2cf53dc7076ebc0be5529d72da832e15989470.tar.bz2
gentoo-8b2cf53dc7076ebc0be5529d72da832e15989470.zip
clean old
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-action/openclonk/files')
-rw-r--r--games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch20
-rw-r--r--games-action/openclonk/files/openclonk-5.5.1-paths.patch67
-rw-r--r--games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch25
3 files changed, 0 insertions, 112 deletions
diff --git a/games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch b/games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch
deleted file mode 100644
index 161258604e6b..000000000000
--- a/games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/graphics/C4SurfaceLoaders.cpp.old 2015-01-02 18:01:35.768676874 +0100
-+++ src/graphics/C4SurfaceLoaders.cpp 2015-01-02 18:02:17.705896683 +0100
-@@ -303,7 +303,7 @@
- // The doc says to give fake end-of-inputs if there is no more data
- cinfo->src->next_input_byte = &end_of_input;
- cinfo->src->bytes_in_buffer = 1;
-- return true;
-+ return (boolean)true;
- }
- static void skip_input_data (j_decompress_ptr cinfo, long num_bytes)
- {
-@@ -354,7 +354,7 @@
- blub.term_source = jpeg_noop;
-
- // a missing image is an error
-- jpeg_read_header(&cinfo, true);
-+ jpeg_read_header(&cinfo, (boolean)true);
-
- // Let libjpeg convert for us
- cinfo.out_color_space = JCS_RGB;
diff --git a/games-action/openclonk/files/openclonk-5.5.1-paths.patch b/games-action/openclonk/files/openclonk-5.5.1-paths.patch
deleted file mode 100644
index 02776e21ed69..000000000000
--- a/games-action/openclonk/files/openclonk-5.5.1-paths.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Thu Feb 6 19:58:45 UTC 2014
-Subject: make paths modifiable
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -35,6 +35,16 @@
- set(${_var} "${_string}" PARENT_SCOPE)
- endfunction()
-
-+
-+############################################################################
-+# User selectable paths
-+############################################################################
-+set(INSTALL_BINDIR "bin/" CACHE PATH "Binary install destination")
-+set(INSTALL_GAMES_BINDIR "games/bin" CACHE PATH "Games binary install destination")
-+set(INSTALL_DATAROOTDIR "share/" CACHE PATH "Data root install destination")
-+set(INSTALL_DATADIR "${INSTALL_DATAROOTDIR}" CACHE PATH "Data install destination")
-+
-+
- ############################################################################
- # User selectable options
- ############################################################################
-@@ -1170,10 +1180,16 @@
- # Assemble compiler flags
- ############################################################################
- if(UNIX)
-+ if(NOT IS_ABSOLUTE "${INSTALL_DATADIR}")
-+ set(ABSOLUTE_INSTALL_DATADIR "${CMAKE_INSTALL_PREFIX}/${INSTALL_DATADIR}")
-+ else()
-+ set(ABSOLUTE_INSTALL_DATADIR "${INSTALL_DATADIR}")
-+ endif()
-+
- # Don't put this into CMAKE_CXX_FLAGS because otherwise it is cached,
- # and when the path is changed both the old and new definition appears
- # in the list of flags.
-- add_definitions("-DOC_SYSTEM_DATA_DIR=\"${CMAKE_INSTALL_PREFIX}/share/games/openclonk\"")
-+ add_definitions("-DOC_SYSTEM_DATA_DIR=\"${ABSOLUTE_INSTALL_DATADIR}/openclonk\"")
- endif()
- if(OC_CXX_FLAGS)
- list(REMOVE_DUPLICATES OC_CXX_FLAGS)
-@@ -1474,20 +1490,20 @@
- DEPENDS c4group
- VERBATIM
- )
-- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${group} DESTINATION share/games/openclonk)
-+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${group} DESTINATION "${INSTALL_DATADIR}/openclonk")
- endif()
- endforeach()
-
- if (NOT APPLE)
- add_custom_target(groups DEPENDS ${OC_C4GROUPS})
- add_dependencies(data groups)
--
-+
- # Install new files
-- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/openclonk.desktop DESTINATION share/applications)
-+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/openclonk.desktop DESTINATION "${INSTALL_DATAROOTDIR}/applications")
-
- # Install binaries
-- install(TARGETS openclonk DESTINATION games)
-- install(TARGETS c4group DESTINATION bin)
-+ install(TARGETS openclonk DESTINATION "${INSTALL_GAMES_BINDIR}")
-+ install(TARGETS c4group DESTINATION "${INSTALL_BINDIR}")
- else()
- install(TARGETS openclonk
- BUNDLE DESTINATION .
diff --git a/games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch b/games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch
deleted file mode 100644
index a55943fc3135..000000000000
--- a/games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Thu Feb 6 19:58:45 UTC 2014
-Subject: use shared tinyxml
-
---- a/CMakeLists.txt.old.new
-+++ b/CMakeLists.txt
-@@ -1292,7 +1292,6 @@
- CHECK_INCLUDE_FILE_CXX(getopt.h HAVE_GETOPT_H)
-
- # TinyXML
--add_subdirectory(thirdparty/tinyxml)
- target_link_libraries(openclonk tinyxml)
-
- if(WIN32)
---- a/src/lib/StdMeshLoaderXml.cpp
-+++ b/src/lib/StdMeshLoaderXml.cpp
-@@ -19,7 +19,7 @@
- #include "C4Include.h"
- #include "StdMesh.h"
- #include "StdMeshLoader.h"
--#include <tinyxml/tinyxml.h>
-+#include <tinyxml.h>
-
- // Helper class to load things from an XML file with error checking
- class StdMeshLoader::StdMeshXML