summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-07-19 18:01:28 +0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-20 15:05:10 +0200
commit4fc16bd6900c8b5f04f8ae131981cfcb49510908 (patch)
treeaf7acc132babd3aad11223d317348e8328d4c27a /games-action
parentdev-ruby/nokogiri: Stabilize 1.16.5 ppc, #936378 (diff)
downloadgentoo-4fc16bd6900c8b5f04f8ae131981cfcb49510908.tar.gz
gentoo-4fc16bd6900c8b5f04f8ae131981cfcb49510908.tar.bz2
gentoo-4fc16bd6900c8b5f04f8ae131981cfcb49510908.zip
games-action/prismlauncher: add 8.4
Remove unnecessary lto and debug useflags which allows removing workarounds. Users are generally supposed to use CXXFLAGS for this. Explicitly unbundle tomlplusplus. Drop nonworking -Werror sed. Last time codebase had a -Werror in CMakeLists.txt the year was 2022. Minor dependency tweaking and reorder eclasses to give cmake priority over java-pkg-2. Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/prismlauncher/Manifest1
-rw-r--r--games-action/prismlauncher/prismlauncher-8.4.ebuild154
2 files changed, 155 insertions, 0 deletions
diff --git a/games-action/prismlauncher/Manifest b/games-action/prismlauncher/Manifest
index eb87ea7ae178..c9c9b2fb19ad 100644
--- a/games-action/prismlauncher/Manifest
+++ b/games-action/prismlauncher/Manifest
@@ -1,2 +1,3 @@
DIST prismlauncher-8.2.tar.gz 8437675 BLAKE2B 3eee060dbc80ca690b344875caa20b27d8949b1e972602d1d383e1ae394404408d74dece11b47f940948ac2c437bd73fadf56d4e492daa34adef1c1eade66bc9 SHA512 6a0988a83e36df0da328fed0efe93171f8b4c565622f8eddf885e6e019214b15b8f64485ce1d9982dd441fad7c4aac8d1647e1b4dbf2cdb8ebadc46f664857ad
DIST prismlauncher-8.3.tar.gz 8412178 BLAKE2B 47244a8ec09ad12bf902660d114835ef0c142dd7cf740e8fe3771c08dd39ff5ab5f9e043d17c03dce1986c0a37b421868d4d3d939b35bdb9c237b2f72925be79 SHA512 c4153fbfd5b6c09ecf2d78d95a629e78685a45a85ccbb5d7f8e4ec7bf7efb66d72f5eee0947ccb13090b4a8429b00cb92fdf96bb0dbe435b61a285d7517d37b2
+DIST prismlauncher-8.4.tar.gz 8444486 BLAKE2B c7950df3d843e370914e2a72c71847a71ab0446508a464ce04ded007b0b3170e8119bb30455d1022fda98cd49f16528a63f5589766561cfc15950c6823779b6f SHA512 24307e6f2a34c459153def5ee639c9a37d3ec3e54bf81dc7d7da8263ee58e16f2391101732889d3b00a1b923704aa21756fad4ee288665e45962032b1d9e8de9
diff --git a/games-action/prismlauncher/prismlauncher-8.4.ebuild b/games-action/prismlauncher/prismlauncher-8.4.ebuild
new file mode 100644
index 000000000000..82820693349e
--- /dev/null
+++ b/games-action/prismlauncher/prismlauncher-8.4.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake java-pkg-2 optfeature toolchain-funcs xdg
+
+DESCRIPTION="A custom, open source Minecraft launcher"
+HOMEPAGE="https://prismlauncher.org/ https://github.com/PrismLauncher/PrismLauncher"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="
+ https://github.com/PrismLauncher/PrismLauncher
+ "
+
+ EGIT_SUBMODULES=(
+ '*' '-libraries/cmark' '-libraries/extra-cmake-modules' '-libraries/filesystem' '-libraries/quazip'
+ '-libraries/tomlplusplus' '-libraries/zlib'
+ )
+else
+ MY_PN="PrismLauncher"
+
+ # Let's use the vendored tarball to avoid dealing with the submodules directly
+ SRC_URI="
+ https://github.com/PrismLauncher/PrismLauncher/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ # The Prism's files are unpacked to ${WORKDIR}/PrismLauncher-${PV}
+ S="${WORKDIR}/${MY_PN}-${PV}"
+
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+# GPL-3 for PolyMC (PrismLauncher is forked from it) and Prism itself
+# Apache-2.0 for MultiMC (PolyMC is forked from it)
+# LGPL-3+ for libnbtplusplus
+# See the rest of PrismLauncher's libraries at https://github.com/PrismLauncher/PrismLauncher/tree/develop/libraries
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2+ GPL-3 ISC LGPL-2.1+ LGPL-3+"
+
+SLOT="0"
+
+IUSE="qt6 test"
+
+RESTRICT="!test? ( test )"
+
+MIN_QT_5_VERSION="5.12.0"
+MIN_QT_6_VERSION="6.0.0"
+
+QT_DEPS="
+ !qt6? (
+ >=dev-qt/qtconcurrent-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtcore-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtgui-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtnetwork-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qttest-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtwidgets-${MIN_QT_5_VERSION}:5
+ >=dev-qt/qtxml-${MIN_QT_5_VERSION}:5
+ )
+
+ qt6? (
+ >=dev-qt/qtbase-${MIN_QT_6_VERSION}:6[concurrent,gui,network,widgets,xml(+)]
+ >=dev-qt/qt5compat-${MIN_QT_6_VERSION}:6
+ )
+"
+
+# Required at both build-time and run-time
+COMMON_DEPENDS="
+ ${QT_DEPS}
+
+ !qt6? ( >=dev-libs/quazip-1.3:=[qt5(+)] )
+ qt6? ( >=dev-libs/quazip-1.3:=[qt6(-)] )
+
+ app-text/cmark:=
+ dev-cpp/tomlplusplus
+ sys-libs/zlib
+"
+
+BDEPEND="
+ app-text/scdoc
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+# The gulrak-filesystem dependency is only needed at build time, because we don't actually use it on Linux,
+# only on legacy macOS. Still, we need it present at build time to appease CMake, and having it like this
+# makes it easier to maintain than patching the CMakeLists file directly.
+DEPEND="
+ ${COMMON_DEPENDS}
+ dev-cpp/gulrak-filesystem
+ media-libs/libglvnd
+ >=virtual/jdk-1.8.0:*
+"
+
+# QtSvg imageplugin needed at runtime for svg icons. Its used via QIcon.
+# At run-time we don't depend on JDK, only JRE
+# And we need more than just the GL headers
+RDEPEND="
+ ${COMMON_DEPENDS}
+
+ !qt6? ( >=dev-qt/qtsvg-${MIN_QT_5_VERSION}:5 )
+ qt6? ( >=dev-qt/qtsvg-${MIN_QT_6_VERSION}:6 )
+
+ >=virtual/jre-1.8.0:*
+ virtual/opengl
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ local java="$(java-config -f)"
+ local java_version=${java//[^0-9]/}
+ if [[ ${java_version} -ge 20 ]]; then
+ elog "Java 20 and up has dropped binary compatibility with java 7."
+ elog "${PN} is being compiled with java ${java_version}."
+ elog "The sources will be patched to build binary compatible with"
+ elog "java 8 instead of java 7. This may cause issues with very old"
+ elog "Minecraft versions and/or older forge versions."
+ elog
+ elog "If you experience any problems, install an older java compiler"
+ elog "and select it with \"eselect java\", then recompile ${PN}."
+ eapply "${FILESDIR}/${PN}-8.2-openjdk21.patch"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ # Resulting binary is named prismlauncher
+ -DLauncher_APP_BINARY_NAME="${PN}"
+ -DLauncher_BUILD_PLATFORM="Gentoo"
+ -DLauncher_QT_VERSION_MAJOR=$(usex qt6 6 5)
+
+ -DENABLE_LTO=$(tc-is-lto)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Original issue: https://github.com/PolyMC/PolyMC/issues/227
+ optfeature "old Minecraft (<= 1.12.2) support" x11-apps/xrandr
+
+ optfeature "built-in MangoHud support" games-util/mangohud
+ optfeature "built-in Feral Gamemode support" games-util/gamemode
+}