summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 00:35:27 +0000
committerSam James <sam@gentoo.org>2021-04-07 01:57:38 +0000
commitb37e88acde2bc04a4d132d0ead74ff7c511260b1 (patch)
tree581d8399f392a6ef0610f0b3e1633baa6d94d1d5 /games-arcade/epiar/files
parentgames-arcade/epiar: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-b37e88acde2bc04a4d132d0ead74ff7c511260b1.tar.gz
gentoo-b37e88acde2bc04a4d132d0ead74ff7c511260b1.tar.bz2
gentoo-b37e88acde2bc04a4d132d0ead74ff7c511260b1.zip
games-arcade/epiar: add 0.5.1
Includes patches to: * Unbundle Lua 5.1 * Fix Bashisms Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade/epiar/files')
-rw-r--r--games-arcade/epiar/files/epiar-0.5.1-fix-bashisms.patch41
-rw-r--r--games-arcade/epiar/files/epiar-0.5.1-unbundle-lua5.1.patch49
2 files changed, 90 insertions, 0 deletions
diff --git a/games-arcade/epiar/files/epiar-0.5.1-fix-bashisms.patch b/games-arcade/epiar/files/epiar-0.5.1-fix-bashisms.patch
new file mode 100644
index 000000000000..cc064799366a
--- /dev/null
+++ b/games-arcade/epiar/files/epiar-0.5.1-fix-bashisms.patch
@@ -0,0 +1,41 @@
+From 99b92a9d29f61beae05227c4f10ed54c41c02b11 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 7 Apr 2021 00:29:01 +0000
+Subject: [PATCH 2/2] Fix bashisms
+
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b5a70d5..4d3d598 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -22,13 +22,13 @@ AC_PROG_RANLIB
+ AC_LANG(C++)
+
+ dnl Check for a C++ compiler
+-if test "$ac_cv_prog_cxx_g" == no
++if test "$ac_cv_prog_cxx_g" = no
+ then
+ AC_MSG_ERROR([Cannot find a working C++ compiler])
+ fi
+
+ dnl Set PKG_CONFIG if necessary
+-if test "$PKG_CONFIG" == ""
++if test "$PKG_CONFIG" = ""
+ then
+ PKG_CONFIG=`which pkg-config`
+ fi
+@@ -71,7 +71,7 @@ AC_CHECK_LIB(physfs, PHYSFS_init, have_physfs_lib=yes)
+ if test x$have_physfs_hdr = xyes -a x$have_physfs_lib = xyes; then
+ enable_physfs="yes"
+ else
+-dnl if test "$ac_cv_prog_cxx_g" == no
++dnl if test "$ac_cv_prog_cxx_g" = no
+ dnl then
+ AC_MSG_ERROR([Could not find PhysicsFS])
+ dnl fi
+--
+2.31.1
+
diff --git a/games-arcade/epiar/files/epiar-0.5.1-unbundle-lua5.1.patch b/games-arcade/epiar/files/epiar-0.5.1-unbundle-lua5.1.patch
new file mode 100644
index 000000000000..e80615e549b6
--- /dev/null
+++ b/games-arcade/epiar/files/epiar-0.5.1-unbundle-lua5.1.patch
@@ -0,0 +1,49 @@
+From 0ed05474a5ea50cc972fae620fd1580ed0026fca Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 7 Apr 2021 00:28:07 +0000
+Subject: [PATCH 1/2] Unbundle Lua 5.1 and dynamically link with system copy
+
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ Makefile.am | 6 ++----
+ configure.ac | 3 +++
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 334b80e..b24ad29 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,4 +1,4 @@
+-AM_CXXFLAGS = -I$(top_srcdir)/source/ -I$(top_srcdir)/source/lua/src
++AM_CXXFLAGS = -I$(top_srcdir)/source/ $(LUA_CFLAGS)
+
+ bin_PROGRAMS = epiar
+
+@@ -74,9 +74,7 @@ epiar_SOURCES = source/main.cpp \
+ source/Utilities/trig.cpp \
+ source/Utilities/xml.cpp
+
+-epiar_LDADD = source/lua/src/liblua.a
+-
+-SUBDIRS=source/lua
++epiar_LDADD = $(LUA_LIBS)
+
+ include resources/Animations/Makefile.am
+ include resources/audio/Makefile.am
+diff --git a/configure.ac b/configure.ac
+index 17202ae..b5a70d5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -99,6 +99,9 @@ case "$target" in *-apple-darwin*)
+ LIBS="$LIBS `xml2-config --libs`"
+ esac
+
++dnl Check for Lua 5.1
++PKG_CHECK_MODULES([LUA], [lua5.1], [], [AC_MSG_ERROR([Could not find needed Lua 5.1])])
++
+ dnl Check for SDL
+ SDL_VERSION=1.2.10
+
+--
+2.31.1
+