summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild')
-rw-r--r--games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild b/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild
new file mode 100644
index 000000000000..33595b80a0d4
--- /dev/null
+++ b/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_P=${P/_/-}
+inherit eutils gnome2-utils perl-module toolchain-funcs games
+
+DESCRIPTION="A Puzzle Bubble clone written in perl (now with network support)"
+HOMEPAGE="http://www.frozen-bubble.org/"
+SRC_URI="http://www.frozen-bubble.org/data/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.12
+ >=dev-libs/glib-2
+ >=dev-perl/Alien-SDL-1.413
+ dev-perl/Compress-Bzip2
+ dev-perl/File-ShareDir
+ dev-perl/File-Slurp
+ dev-perl/File-Which
+ dev-perl/IPC-System-Simple
+ >=dev-perl/SDL-2.511
+ media-libs/sdl-image[gif,png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-pango
+ media-libs/sdl-ttf
+ virtual/libiconv
+ virtual/perl-Getopt-Long
+ virtual/perl-IO"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-perl/Locale-Maketext-Lexicon
+ virtual/perl-ExtUtils-CBuilder
+ virtual/perl-ExtUtils-ParseXS
+ dev-perl/Module-Build"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ perl-module_src_prepare
+ epatch "${FILESDIR}"/${P}-Werror.patch
+}
+
+src_configure() {
+ LD=$(tc-getCC) perl-module_src_configure
+}
+
+src_compile() {
+ LD=$(tc-getCC) perl-module_src_compile
+}
+
+src_install() {
+ mydoc="AUTHORS Changes HISTORY README" perl-module_src_install
+
+ dodir "${GAMES_BINDIR}"
+ mv -vf "${D}"/usr/bin/f* "${D}/${GAMES_BINDIR}" || die
+
+ newdoc server/README README.server
+ newdoc server/init/README README.server.init
+
+ local res
+ for res in 16 32 48 64; do
+ newicon -s ${res} share/icons/frozen-bubble-icon-${res}x${res}.png ${PN}.png
+ done
+
+ make_desktop_entry ${PN} Frozen-Bubble
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}