summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-23 20:07:10 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-23 21:16:56 +0200
commitbf2a9ad5179cc48817e2a42f7dd5902680b3ea41 (patch)
treedd10bd5a6281e050d12375242fd8a76526c48627 /games-arcade/pacmanarena/pacmanarena-0.15-r1.ebuild
parentgames-arcade/njam: Drop old (diff)
downloadgentoo-bf2a9ad5179cc48817e2a42f7dd5902680b3ea41.tar.gz
gentoo-bf2a9ad5179cc48817e2a42f7dd5902680b3ea41.tar.bz2
gentoo-bf2a9ad5179cc48817e2a42f7dd5902680b3ea41.zip
games-arcade/pacmanarena: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade/pacmanarena/pacmanarena-0.15-r1.ebuild')
-rw-r--r--games-arcade/pacmanarena/pacmanarena-0.15-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-arcade/pacmanarena/pacmanarena-0.15-r1.ebuild b/games-arcade/pacmanarena/pacmanarena-0.15-r1.ebuild
new file mode 100644
index 000000000000..e803d7748359
--- /dev/null
+++ b/games-arcade/pacmanarena/pacmanarena-0.15-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="3D Pacman clone with a few surprises. Rockets, bombs and explosions abound"
+HOMEPAGE="http://pacmanarena.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/pacman-arena-${PV}.tar.bz2
+ mirror://sourceforge/${PN}/pacman-data-0.0.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl[sound]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+S="${WORKDIR}/pacman"
+
+src_unpack() {
+ unpack pacman-arena-${PV}.tar.bz2
+ cd "${S}"
+ unpack pacman-data-0.0.zip
+}
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/^CFLAGS/ s:pacman:${PN}:" \
+ -e '1i CC=@CC@' \
+ Makefile.in || die
+ sed -i \
+ -e '/CFLAGS/s:-g::' \
+ configure || die
+ eapply "${FILESDIR}"/${P}-underlink.patch
+ eautoreconf
+}
+
+src_install() {
+ newbin pacman ${PN}
+ insinto /usr/share/${PN}
+ doins -r gfx sfx
+ newicon gfx/pacman_arena1.tga ${PN}.tga
+ make_desktop_entry ${PN} "Pacman Arena" /usr/share/pixmaps/${PN}.tga
+ einstalldocs
+}