summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-24 19:15:46 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-24 21:25:52 +0200
commit6feb621050c725cef70fb2d4f859222494a9d99d (patch)
treee9bf500400b9b4163eb52bfbf724681abdd865c6 /games-arcade/sable/sable-1.0-r1.ebuild
parentapp-doc/zeal: Clean old (diff)
downloadgentoo-6feb621050c725cef70fb2d4f859222494a9d99d.tar.gz
gentoo-6feb621050c725cef70fb2d4f859222494a9d99d.tar.bz2
gentoo-6feb621050c725cef70fb2d4f859222494a9d99d.zip
games-arcade/sable: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade/sable/sable-1.0-r1.ebuild')
-rw-r--r--games-arcade/sable/sable-1.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-arcade/sable/sable-1.0-r1.ebuild b/games-arcade/sable/sable-1.0-r1.ebuild
new file mode 100644
index 000000000000..9ff9a086c60e
--- /dev/null
+++ b/games-arcade/sable/sable-1.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A frantic 3D space shooter"
+HOMEPAGE="http://jeuxlibres.net/showgame/sable.html"
+SRC_URI="mirror://gentoo/${P}-src.tgz
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/libsdl[joystick,opengl,sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ emake INSTALL_RESDIR="/usr/share"
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r models sfx textures
+ einstalldocs
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Sable
+}