summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-28 03:12:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-28 12:42:38 -0400
commit3113c776c9a79ce989152d78bb5d17cb7b773954 (patch)
treebe56584678c7d3a81e78dda05ec7dc5ecc4cb473 /games-arcade/vor/vor-0.5.8.ebuild
parentgames-arcade/pengupop: EAPI 6->8, simplify ebuild (diff)
downloadgentoo-3113c776c9a79ce989152d78bb5d17cb7b773954.tar.gz
gentoo-3113c776c9a79ce989152d78bb5d17cb7b773954.tar.bz2
gentoo-3113c776c9a79ce989152d78bb5d17cb7b773954.zip
games-arcade/vor: add 0.5.8, EAPI 6->8
This version also fixes previous gcc10/-fno-common issues. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade/vor/vor-0.5.8.ebuild')
-rw-r--r--games-arcade/vor/vor-0.5.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-arcade/vor/vor-0.5.8.ebuild b/games-arcade/vor/vor-0.5.8.ebuild
new file mode 100644
index 000000000000..2bc45bd9b394
--- /dev/null
+++ b/games-arcade/vor/vor-0.5.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Variations on Rockdodger: Dodge the rocks until you die"
+HOMEPAGE="https://jasonwoof.org/vor"
+SRC_URI="https://jasonwoof.com/downloads/vor/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dodir /usr/bin
+
+ default
+
+ newicon data/icon.png ${PN}.png
+ make_desktop_entry ${PN} VoR
+}