summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-24 04:13:10 +0100
committerSam James <sam@gentoo.org>2024-06-24 04:13:10 +0100
commit110a607831ef21af82c02f547cbcf0556d24376c (patch)
tree530feae799e4d80115bf03339501f99ced563150 /games-arcade
parentapp-dicts/verbiste: add missing test dep(s) (diff)
downloadgentoo-110a607831ef21af82c02f547cbcf0556d24376c.tar.gz
gentoo-110a607831ef21af82c02f547cbcf0556d24376c.tar.bz2
gentoo-110a607831ef21af82c02f547cbcf0556d24376c.zip
games-arcade/frozen-bubble: fix build w/ perl-5.40
Closes: https://bugs.gentoo.org/934245 Thanks-to: Torsten Kaiser Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/frozen-bubble/files/frozen-bubble-2.2.1_beta1-perl-5.40.patch16
-rw-r--r--games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1-r2.ebuild3
2 files changed, 18 insertions, 1 deletions
diff --git a/games-arcade/frozen-bubble/files/frozen-bubble-2.2.1_beta1-perl-5.40.patch b/games-arcade/frozen-bubble/files/frozen-bubble-2.2.1_beta1-perl-5.40.patch
new file mode 100644
index 000000000000..ba22b139e16c
--- /dev/null
+++ b/games-arcade/frozen-bubble/files/frozen-bubble-2.2.1_beta1-perl-5.40.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/934245
+
+Fix build error:
+Attempt to call undefined import method with arguments ("0.36") via package "Module::Build" (Perhaps you forgot to load the package?) at inc/My/Builder.pm line 11.
+
+--- a/inc/My/Builder.pm
++++ b/inc/My/Builder.pm
+@@ -8,7 +8,7 @@
+ use File::Slurp qw(read_file write_file);
+ use File::Spec::Functions qw(catdir catfile rootdir);
+ use IO::File qw();
+-use Module::Build '0.36' => qw();
++use Module::Build qw();
+ use autodie qw(:all move read_file write_file);
+ use parent 'Module::Build';
+ use Locale::Maketext::Extract;
diff --git a/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1-r2.ebuild b/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1-r2.ebuild
index 3a75e5deb783..28f22c8bcc99 100644
--- a/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1-r2.ebuild
+++ b/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -44,6 +44,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-Werror.patch
"${FILESDIR}"/${P}-fix-buffer-size.patch
+ "${FILESDIR}"/${P}-perl-5.40.patch
)
src_configure() {