summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-08-02 22:06:10 +0200
committerJames Le Cuirot <chewi@gentoo.org>2024-08-07 21:36:30 +0100
commite061aa8dcf03e6463ca3677064bde18303908933 (patch)
tree384e66eeccb89f631ab31aa9548eb56b892d8652 /games-arcade
parentmedia-libs/alure: Fix flag handling in newer CMake with patch, don't dlopen deps (diff)
downloadgentoo-e061aa8dcf03e6463ca3677064bde18303908933.tar.gz
gentoo-e061aa8dcf03e6463ca3677064bde18303908933.tar.bz2
gentoo-e061aa8dcf03e6463ca3677064bde18303908933.zip
games-arcade/apricots: add 0.2.8
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37932 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/apricots/Manifest1
-rw-r--r--games-arcade/apricots/apricots-0.2.8.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/games-arcade/apricots/Manifest b/games-arcade/apricots/Manifest
index 777ad348f175..562502297719 100644
--- a/games-arcade/apricots/Manifest
+++ b/games-arcade/apricots/Manifest
@@ -1,2 +1,3 @@
DIST apricots-0.2.7.tar.gz 388024 BLAKE2B 5d16cb2637580ae728aa4f1b3911801effa6c79faabf7f3a1c026de8d91aaa582c8063ae33152c44fc9878ae0f7126fdb6ab0363b562e90c7359bcfe6ac78391 SHA512 7f97759402703962f660cdf609f50bb9a4465cc727d3fd17751eb5863b0b9131d9014eab50632c1638130f7e4223c89c45c12cecbc9fe2639943def2ce80ae25
+DIST apricots-0.2.8.tar.gz 407430 BLAKE2B 7ae24c5d068ef528ee5352088ffea6f747b01e418e94e93b87795f6ccda5101ebf27cfb7d7c51f1e076cec71c39fce5f06ff16644d924a03df7bd5c24f4e56aa SHA512 4d08ba96087ef811bc30a70ce3963c1c0633fd7fcb2d628d0986f2a35eb89284e78be26a3cccc133cb0beaaeb7923630aeba81b02ad752dcd46d31bcb1165322
DIST apricots.png 1965 BLAKE2B 164e06ec9856273077636b347cac555cc49f5f38faffeea6f43b9032edee9dfebedce24470f70b185707ee2e467d861164a9c90c370ada5ff89d5c4854b99e7c SHA512 5d637707d7cfa775e5f3d3416a51abbbb39369cf0bfd9be871295ca3079530c25b893076c2cb6a6621586d67860920e079cb4f491d2c67ff13ce80e56a2cf4e5
diff --git a/games-arcade/apricots/apricots-0.2.8.ebuild b/games-arcade/apricots/apricots-0.2.8.ebuild
new file mode 100644
index 000000000000..d4716a1a5e94
--- /dev/null
+++ b/games-arcade/apricots/apricots-0.2.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Fly a plane around and bomb/shoot the enemy (port of Planegame from Amiga)"
+HOMEPAGE="https://github.com/moggers87/apricots"
+SRC_URI="
+ https://github.com/moggers87/apricots/releases/download/v${PV}/${P}.tar.gz
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="test" # this is only static analysis / linter tests
+
+RDEPEND="
+ media-libs/alure
+ media-libs/freealut
+ media-libs/libsdl2[sound,video]
+ media-libs/openal"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ default
+ einstalldocs
+
+ insinto /etc
+ doins ${PN}/${PN}.cfg
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} ${PN^}
+}