summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-25 20:26:02 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-25 20:29:40 +0200
commite8f837187411c684183debc5f8bbc5d0d6c60b31 (patch)
treef2079668c9d4d794c8a96bb44a69cfbde22100aa /games-arcade
parentgames-arcade/xtux: Drop old (diff)
downloadgentoo-e8f837187411c684183debc5f8bbc5d0d6c60b31.tar.gz
gentoo-e8f837187411c684183debc5f8bbc5d0d6c60b31.tar.bz2
gentoo-e8f837187411c684183debc5f8bbc5d0d6c60b31.zip
games-arcade/yarsrevenge: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/yarsrevenge/files/0.99-math.patch4
-rw-r--r--games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc43.patch4
-rw-r--r--games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc44.patch4
-rw-r--r--games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild30
4 files changed, 36 insertions, 6 deletions
diff --git a/games-arcade/yarsrevenge/files/0.99-math.patch b/games-arcade/yarsrevenge/files/0.99-math.patch
index 5d7d4619d9c5..5e1136972325 100644
--- a/games-arcade/yarsrevenge/files/0.99-math.patch
+++ b/games-arcade/yarsrevenge/files/0.99-math.patch
@@ -1,5 +1,5 @@
---- yar/graphics.cpp.orig 2004-06-02 14:14:38.174071320 -0400
-+++ yar/graphics.cpp 2004-06-02 14:14:50.352219960 -0400
+--- a/yar/graphics.cpp.orig 2004-06-02 14:14:38.174071320 -0400
++++ b/yar/graphics.cpp 2004-06-02 14:14:50.352219960 -0400
@@ -18,2 +18,3 @@
#include "yar.hxx"
+#include <cmath>
diff --git a/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc43.patch b/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc43.patch
index fe32b6c74e6c..511fad0091e1 100644
--- a/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc43.patch
+++ b/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc43.patch
@@ -1,5 +1,5 @@
---- yar/sgw.hxx
-+++ yar/sgw.hxx
+--- a/yar/sgw.hxx
++++ b/yar/sgw.hxx
@@ -24,6 +24,7 @@
#include <iostream>
diff --git a/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc44.patch b/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc44.patch
index fca41cfbdf35..29a52125c904 100644
--- a/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc44.patch
+++ b/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc44.patch
@@ -1,5 +1,5 @@
---- yar/game.cpp
-+++ yar/game.cpp
+--- a/yar/game.cpp
++++ b/yar/game.cpp
@@ -15,6 +15,7 @@
* *
***************************************************************************/
diff --git a/games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild b/games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild
new file mode 100644
index 000000000000..b6923570b8f4
--- /dev/null
+++ b/games-arcade/yarsrevenge/yarsrevenge-0.99-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Remake of the Atari 2600 classic Yar's Revenge"
+HOMEPAGE="http://freshmeat.net/projects/yarsrevenge/"
+SRC_URI="http://www.autismuk.freeserve.co.uk/yar-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/yar-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-math.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
+
+src_install() {
+ default
+ make_desktop_entry "${PN}" "Yar's Revenge"
+}