summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/qcheckers
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/qcheckers')
-rw-r--r--games-board/qcheckers/Manifest1
-rw-r--r--games-board/qcheckers/metadata.xml8
-rw-r--r--games-board/qcheckers/qcheckers-20091230.ebuild34
3 files changed, 43 insertions, 0 deletions
diff --git a/games-board/qcheckers/Manifest b/games-board/qcheckers/Manifest
new file mode 100644
index 000000000000..d6573d131b85
--- /dev/null
+++ b/games-board/qcheckers/Manifest
@@ -0,0 +1 @@
+DIST QCheckers-20091230.tar.gz 45259 SHA256 a98946a26237ea267fe218f5edb06378a432c8f46a22a17463ed2e5c39559fe1 SHA512 c2cdb679a13804723064e87be1879185d14618e5147ead93b65a65d02100f3c47bed9243d845754b3aa862a0d4f7c803e5df42fa3bc3513b08a9a08b611a3d90 WHIRLPOOL 1bd77aa93df40c6fe27378ecce0c17e35e3919e0579942b07ea33eac1aab815413e8cc76feb34940b8ef9cfd76de051f39c114a8247d1f6f392649c0c7aea02f
diff --git a/games-board/qcheckers/metadata.xml b/games-board/qcheckers/metadata.xml
new file mode 100644
index 000000000000..3b41977892d3
--- /dev/null
+++ b/games-board/qcheckers/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="google-code">qcheckers</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-board/qcheckers/qcheckers-20091230.ebuild b/games-board/qcheckers/qcheckers-20091230.ebuild
new file mode 100644
index 000000000000..ef7526b76912
--- /dev/null
+++ b/games-board/qcheckers/qcheckers-20091230.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils qt4-r2 games
+
+MY_PN=${PN/qc/QC}
+
+DESCRIPTION="Qt4 based checkers game"
+HOMEPAGE="http://code.google.com/p/qcheckers/"
+SRC_URI="http://qcheckers.googlecode.com/files/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_PN}
+
+src_configure() {
+ eqmake4 ${MY_PN}.pro
+}
+
+src_install() {
+ dogamesbin ${MY_PN}
+ newicon icons/help-about.png ${PN}.png
+ make_desktop_entry ${MY_PN} ${MY_PN}
+ dodoc README
+ prepgamesdirs
+}