summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-01 15:48:48 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-01 16:09:53 -0500
commit64ff382c446b56b1d17fc93cf76d2c840967caad (patch)
tree440a6f12f24fcc15849620473b84c1f458e0ac78 /games-board
parentsci-libs/fftw: live ebuild update (diff)
downloadgentoo-64ff382c446b56b1d17fc93cf76d2c840967caad.tar.gz
gentoo-64ff382c446b56b1d17fc93cf76d2c840967caad.tar.bz2
gentoo-64ff382c446b56b1d17fc93cf76d2c840967caad.zip
games-board/sirius: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board')
-rw-r--r--games-board/sirius/files/sirius-0.8.0-format.patch4
-rw-r--r--games-board/sirius/sirius-0.8.0-r1.ebuild49
2 files changed, 51 insertions, 2 deletions
diff --git a/games-board/sirius/files/sirius-0.8.0-format.patch b/games-board/sirius/files/sirius-0.8.0-format.patch
index dccf6e244323..8dff431bf792 100644
--- a/games-board/sirius/files/sirius-0.8.0-format.patch
+++ b/games-board/sirius/files/sirius-0.8.0-format.patch
@@ -1,5 +1,5 @@
---- src/sirius.c.old 2016-01-14 21:22:53.946900371 +0100
-+++ src/sirius.c 2016-01-14 21:24:08.240507669 +0100
+--- a/src/sirius.c 2016-01-14 21:22:53.946900371 +0100
++++ b/src/sirius.c 2016-01-14 21:24:08.240507669 +0100
@@ -180,7 +180,7 @@
paus = 1;
diff --git a/games-board/sirius/sirius-0.8.0-r1.ebuild b/games-board/sirius/sirius-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..443de7db7aa0
--- /dev/null
+++ b/games-board/sirius/sirius-0.8.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A program for playing the game of othello/reversi"
+HOMEPAGE="http://sirius.bitvis.nu/"
+SRC_URI="http://sirius.bitvis.nu/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ gnome-base/gconf:2
+ gnome-base/libgnomecanvas
+ gnome-base/libgnomeui
+ x11-libs/gtk+:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e '/-g -O3/d' configure.in || die
+ sed -i \
+ -e '/Icon/s/\.png//' \
+ -e '/Categories/s/Application;//' \
+ sirius.desktop.in || die
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --datadir=/usr/share \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+}