summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-12-27 17:13:30 -0800
committerSam James <sam@gentoo.org>2023-01-15 14:16:11 +0000
commit39fe796bbea11be1cbf11f9278c47456ec1de2b0 (patch)
tree3250aa064f92cfdef5608361cb4ec760583a417d /games-emulation/bsnes-jg
parentgames-emulation/jgrf: New package, v1.0.0 (diff)
downloadgentoo-39fe796bbea11be1cbf11f9278c47456ec1de2b0.tar.gz
gentoo-39fe796bbea11be1cbf11f9278c47456ec1de2b0.tar.bz2
gentoo-39fe796bbea11be1cbf11f9278c47456ec1de2b0.zip
games-emulation/bsnes-jg: New package, v1.1.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation/bsnes-jg')
-rw-r--r--games-emulation/bsnes-jg/Manifest1
-rw-r--r--games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild46
-rw-r--r--games-emulation/bsnes-jg/bsnes-jg-9999.ebuild46
-rw-r--r--games-emulation/bsnes-jg/metadata.xml21
4 files changed, 114 insertions, 0 deletions
diff --git a/games-emulation/bsnes-jg/Manifest b/games-emulation/bsnes-jg/Manifest
new file mode 100644
index 000000000000..15755cbefba4
--- /dev/null
+++ b/games-emulation/bsnes-jg/Manifest
@@ -0,0 +1 @@
+DIST bsnes-1.1.0.tar.bz2 4181355 BLAKE2B c60181208455f14c722073f7aa43b6b988aa46d8614cc8eae6e6b47acf1c5b30a94aa04410f873531e73637d3f11e25297dccc80b5c15c9fa4d4cc207083cef9 SHA512 39ee7e04dbeb021ac041ca3d189b86cf76f1994561c4bd1fd77a532e87ef4c135b177700b62f6e4f07018953c34f8602b5c4a43cd22d51dcd047df71e77e0412
diff --git a/games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild b/games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild
new file mode 100644
index 000000000000..24d855263f55
--- /dev/null
+++ b/games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of bsnes"
+HOMEPAGE="https://gitlab.com/jgemu/bsnes"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ISC GPL-3+ LGPL-2.1+ MIT ZLIB"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/libsamplerate
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/bsnes-jg/bsnes-jg-9999.ebuild b/games-emulation/bsnes-jg/bsnes-jg-9999.ebuild
new file mode 100644
index 000000000000..24d855263f55
--- /dev/null
+++ b/games-emulation/bsnes-jg/bsnes-jg-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of bsnes"
+HOMEPAGE="https://gitlab.com/jgemu/bsnes"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ISC GPL-3+ LGPL-2.1+ MIT ZLIB"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/libsamplerate
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/bsnes-jg/metadata.xml b/games-emulation/bsnes-jg/metadata.xml
new file mode 100644
index 000000000000..8d62f9db73ee
--- /dev/null
+++ b/games-emulation/bsnes-jg/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ bsnes-jg is a cycle accurate emulator for the Super Famicom/Super
+ Nintendo Entertainment System, including support for the Super Game Boy,
+ BS-X Satellaview, and Sufami Turbo.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/bsnes/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/bsnes</remote-id>
+ </upstream>
+</pkgmetadata>