summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-emulation/gfceux
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-emulation/gfceux')
-rw-r--r--games-emulation/gfceux/Manifest1
-rw-r--r--games-emulation/gfceux/files/gfceux-2.1.1-gentoo.patch18
-rw-r--r--games-emulation/gfceux/gfceux-2.1.1-r1.ebuild71
-rw-r--r--games-emulation/gfceux/metadata.xml8
4 files changed, 98 insertions, 0 deletions
diff --git a/games-emulation/gfceux/Manifest b/games-emulation/gfceux/Manifest
new file mode 100644
index 000000000000..924bc975bc8b
--- /dev/null
+++ b/games-emulation/gfceux/Manifest
@@ -0,0 +1 @@
+DIST fceux-2.1.1.src.tar.bz2 3263945 SHA256 5f668de5870e28e4b52fcf8816c17831c0f9597307bd643c226a616a1766bdab SHA512 19a1253a3ff1d88baec5636dbebab287b106e5e114081ab4040f52dfcda28b878af748a759e08dc2fe1381eb8f59e728d36993a9aca9ce184ed8760114cf3149 WHIRLPOOL 198d60dd85064f1a865d710b2da7b7fe883d39a2ec8cc111a407fdff78c43b0f7a0840d2b03717bbff46af8c1ec8aaf91bba3ae44fee6112c956b1a59c7075b7
diff --git a/games-emulation/gfceux/files/gfceux-2.1.1-gentoo.patch b/games-emulation/gfceux/files/gfceux-2.1.1-gentoo.patch
new file mode 100644
index 000000000000..b8eee53a4b88
--- /dev/null
+++ b/games-emulation/gfceux/files/gfceux-2.1.1-gentoo.patch
@@ -0,0 +1,18 @@
+diff -ru gfceux.orig/src/main.py gfceux/src/main.py
+--- gfceux.orig/src/main.py 2009-04-29 01:09:52.000000000 -0400
++++ gfceux/src/main.py 2009-09-29 00:38:53.152619918 -0400
+@@ -279,12 +279,8 @@
+ def load_ui(self):
+ global widgets
+ """ Search for the glade XML file and load it """
+- # Check first in the directory of this script.
+- if os.path.isfile('data/gfceux.glade'):
+- glade_file = 'data/gfceux.glade'
+- # Then check to see if its installed on a *nix system
+- elif os.path.isfile(os.path.join(os.path.dirname(sys.argv[0]), '../share/gfceux/gfceux.glade')):
+- glade_file = os.path.join(os.path.dirname(sys.argv[0]), '../share/gfceux/gfceux.glade')
++ if os.path.isfile('/usr/share/gfceux/gfceux.glade'):
++ glade_file = '/usr/share/gfceux/gfceux.glade'
+ else:
+ print 'ERROR.'
+ print 'Could not find the glade UI file.'
diff --git a/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild b/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..e9218d0ef88d
--- /dev/null
+++ b/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2-utils distutils-r1 games
+
+DESCRIPTION="A graphical frontend for the FCEUX emulator"
+HOMEPAGE="http://fceux.com"
+SRC_URI="mirror://sourceforge/fceultra/fceux-${PV}.src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pygtk"
+RDEPEND="${DEPEND}
+ games-emulation/fceux"
+
+S=${WORKDIR}/${PN}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -i \
+ -e "s#data/gfceux.glade#${GAMES_DATADIR}/${PN}/gfceux.glade#" \
+ src/main.py || die
+}
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doicon -s 48 data/${PN}.png
+ newicon -s 128 data/${PN}_big.png ${PN}.png
+
+ # respect games variables
+ dodir "${GAMES_DATADIR}"/${PN}
+ mv "${ED}"/usr/share/${PN}/* "${ED}${GAMES_DATADIR}"/${PN}/ || die
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-emulation/gfceux/metadata.xml b/games-emulation/gfceux/metadata.xml
new file mode 100644
index 000000000000..ee1fe81755b2
--- /dev/null
+++ b/games-emulation/gfceux/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">fceultra</remote-id>
+ </upstream>
+</pkgmetadata>