summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-12-13 18:05:36 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-12-13 18:38:23 -0500
commitf4584e11b9e82e20a5506b912d21c7c6140a996f (patch)
tree48837e354bd9b6a70814ad1aa082510599073455 /games-emulation/mgba
parentgames-arcade/cdogs-sdl: add 2.2.0 (diff)
downloadgentoo-f4584e11b9e82e20a5506b912d21c7c6140a996f.tar.gz
gentoo-f4584e11b9e82e20a5506b912d21c7c6140a996f.tar.bz2
gentoo-f4584e11b9e82e20a5506b912d21c7c6140a996f.zip
games-emulation/mgba: drop qt5 support in live
We're actively trying to drop Qt5 where possible, and see no reason to keep this here. Also fix linguist-tools dependency BDEPEND which ignored qt6. May need other updates, but have not looked closely (will do when mgba 0.11 releases). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/mgba')
-rw-r--r--games-emulation/mgba/mgba-9999.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/games-emulation/mgba/mgba-9999.ebuild b/games-emulation/mgba/mgba-9999.ebuild
index afc5b4396e02..a599c0cec301 100644
--- a/games-emulation/mgba/mgba-9999.ebuild
+++ b/games-emulation/mgba/mgba-9999.ebuild
@@ -21,7 +21,7 @@ LICENSE="MPL-2.0 BSD LGPL-2.1+ public-domain discord? ( MIT )"
SLOT="0/$(ver_cut 1-2)"
IUSE="
debug discord elf ffmpeg gles2 gles3 gui libretro
- lua +opengl qt6 +sdl +sqlite test
+ lua +opengl +sdl +sqlite test
"
REQUIRED_USE="
gui? ( || ( gles2 gles3 opengl ) sqlite )
@@ -43,17 +43,8 @@ RDEPEND="
)
opengl? ( media-libs/libglvnd )
gui? (
- qt6? (
- dev-qt/qtbase:6[gui,network,opengl,widgets]
- dev-qt/qtmultimedia:6
- )
- !qt6? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
- )
+ dev-qt/qtbase:6[gui,network,opengl,widgets]
+ dev-qt/qtmultimedia:6
)
sdl? ( media-libs/libsdl2[sound,joystick,gles2?,opengl?,video] )
sqlite? ( dev-db/sqlite:3 )
@@ -63,7 +54,7 @@ DEPEND="
test? ( dev-util/cmocka )
"
BDEPEND="
- gui? ( dev-qt/linguist-tools:5 )
+ gui? ( dev-qt/qttools:6[linguist] )
lua? ( virtual/pkgconfig )
"
@@ -83,7 +74,7 @@ src_configure() {
-DBUILD_GLES3=$(usex gles3)
-DBUILD_LIBRETRO=$(usex libretro)
-DBUILD_QT=$(usex gui)
- $(usev gui -DFORCE_QT_VERSION=$(usex qt6 6 5))
+ $(usev gui -DFORCE_QT_VERSION=6)
-DBUILD_ROM_TEST=yes #918855
-DBUILD_SDL=$(usex sdl) # also used for gamepads in QT build
-DBUILD_SUITE=$(usex test)