summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-19 06:09:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-19 07:35:34 -0400
commita5c243495666fd87f2d022bac33d5a43c7eaa07f (patch)
tree48d9558ad495fc4c47d734fa5d6e606e4389956d /games-emulation/pcsx2
parentgames-emulation/pcsx2: depend on old pcsx2_patches for 1.7.4940 (diff)
downloadgentoo-a5c243495666fd87f2d022bac33d5a43c7eaa07f.tar.gz
gentoo-a5c243495666fd87f2d022bac33d5a43c7eaa07f.tar.bz2
gentoo-a5c243495666fd87f2d022bac33d5a43c7eaa07f.zip
games-emulation/pcsx2: install in mono path, handle translations
Translations ignore AppRoot and insist on using the location that pcsx2 is at. Rather than modify further, install everything in /usr/lib/${PN} and keep a symlink for PATH (fortunately using a wrapper does not seem necessary). Unfortunately upstream has no interest in a more standard installation so this may be better going forward. Also tidy a bit. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/pcsx2')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index bb34c0a768df..7024be408faa 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -55,7 +55,7 @@ COMMON_DEPEND="
# is missing and it is fairly small (installs a ~1.5MB patches.zip)
RDEPEND="
${COMMON_DEPEND}
- games-emulation/pcsx2_patches
+ >=games-emulation/pcsx2_patches-0_p20230917
"
DEPEND="
${COMMON_DEPEND}
@@ -69,10 +69,6 @@ BDEPEND="
)
"
-FILECAPS=(
- -m 0755 "CAP_NET_RAW+eip CAP_NET_ADMIN+eip" usr/bin/pcsx2
-)
-
PATCHES=(
"${FILESDIR}"/${PN}-1.7.3468-cubeb-automagic.patch
"${FILESDIR}"/${PN}-1.7.3773-lto.patch
@@ -82,9 +78,6 @@ PATCHES=(
src_prepare() {
cmake_src_prepare
- sed -e "/AppRoot =/s|=.*|= \"${EPREFIX}/usr/share/${PN}\";|" \
- -i pcsx2/Pcsx2Config.cpp || die
-
if [[ ${PV} != 9999 ]]; then
sed -e '/set(PCSX2_GIT_TAG "")/s/""/"v'${PV}-gentoo'"/' \
-i cmake/Pcsx2Utils.cmake || die
@@ -134,19 +127,22 @@ src_test() {
}
src_install() {
- newbin "${BUILD_DIR}"/bin/pcsx2-qt ${PN}
-
- insinto /usr/share/${PN}
- doins -r "${BUILD_DIR}"/bin/resources
+ insinto /usr/lib/${PN}
+ doins -r "${BUILD_DIR}"/bin/.
- dodoc README.md bin/docs/{Debugger.pdf,GameIndex.pdf,debugger.txt}
+ fperms +x /usr/lib/${PN}/pcsx2-qt
+ dosym -r /usr/lib/${PN}/pcsx2-qt /usr/bin/${PN}
newicon bin/resources/icons/AppIconLarge.png ${PN}.png
make_desktop_entry ${PN} ${PN^^}
+
+ dodoc README.md bin/docs/{Debugger.pdf,GameIndex.pdf,debugger.txt}
+
+ use !test || rm "${ED}"/usr/lib/${PN}/*_test || die
}
pkg_postinst() {
- fcaps_pkg_postinst
+ fcaps -m 0755 cap_net_admin,cap_net_raw=eip usr/lib/${PN}/pcsx2-qt
local replacing=
if [[ ${REPLACING_VERSIONS##* } ]]; then