summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-15 00:01:03 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-15 02:26:52 -0500
commit5d465d5586178c6441289109e789cbec2a331118 (patch)
treed02e784ddae4d9012c051e2e5397502b4c06631d /games-emulation
parentdev-python/service-identity: Bump to 24.1.0 (diff)
downloadgentoo-5d465d5586178c6441289109e789cbec2a331118.tar.gz
gentoo-5d465d5586178c6441289109e789cbec2a331118.tar.bz2
gentoo-5d465d5586178c6441289109e789cbec2a331118.zip
games-emulation/pcsx2: force-remove lower bounds on Qt6 and SDL2
Upstream likes to bump these to very recent ones at arbitrary points without seemingly being truly required. Needed to be able to stabilize pcsx2 without bothering to stable libsdl2-2.28.4 "right now" when 2.28.3 seems just fine still. pcsx2-9999 had already needed to switch to 2.28.5 too (why..?). If a version is found problematic, will add the needed lower bound to *DEPEND only. Odds are very old Qt6 (e.g. 6.2) is likely broken but these are long gone and won't worry about it. Using sed given versions keep changing and want to avoid rebasing a patch every time. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/pcsx2-1.7.5312.ebuild14
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild16
2 files changed, 21 insertions, 9 deletions
diff --git a/games-emulation/pcsx2/pcsx2-1.7.5312.ebuild b/games-emulation/pcsx2/pcsx2-1.7.5312.ebuild
index 223990367c6d..dfb2a1b447ac 100644
--- a/games-emulation/pcsx2/pcsx2-1.7.5312.ebuild
+++ b/games-emulation/pcsx2/pcsx2-1.7.5312.ebuild
@@ -31,11 +31,11 @@ RESTRICT="!test? ( test )"
COMMON_DEPEND="
app-arch/xz-utils
dev-libs/libaio
- >=dev-qt/qtbase-6.6.0:6[gui,widgets]
- >=dev-qt/qtsvg-6.6.0:6
+ dev-qt/qtbase:6[gui,widgets]
+ dev-qt/qtsvg:6
media-libs/libglvnd
media-libs/libpng:=
- >=media-libs/libsdl2-2.28.4[haptic,joystick]
+ media-libs/libsdl2[haptic,joystick]
media-video/ffmpeg:=
net-libs/libpcap
net-misc/curl
@@ -61,7 +61,7 @@ DEPEND="
x11-base/xorg-proto
"
BDEPEND="
- >=dev-qt/qttools-6.6.0:6[linguist]
+ dev-qt/qttools:6[linguist]
wayland? (
dev-util/wayland-scanner
kde-frameworks/extra-cmake-modules
@@ -81,6 +81,12 @@ src_prepare() {
sed -e '/set(PCSX2_GIT_TAG "")/s/""/"v'${PV}'"/' \
-i cmake/Pcsx2Utils.cmake || die
fi
+
+ # relax Qt6 and SDL2 version requirements which often get restricted
+ # without a specific need, please report a bug to Gentoo (not upstream)
+ # if a still-available older version is really causing issues
+ sed -e '/find_package(\(Qt6\|SDL2\)/s/ [0-9.]*//' \
+ -i cmake/SearchForStuff.cmake || die
}
src_configure() {
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 43536202eed1..178e5a77996c 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -33,11 +33,11 @@ COMMON_DEPEND="
app-arch/xz-utils
app-arch/zstd:=
dev-libs/libaio
- >=dev-qt/qtbase-6.6.0:6[gui,widgets]
- >=dev-qt/qtsvg-6.6.0:6
+ dev-qt/qtbase:6[gui,widgets]
+ dev-qt/qtsvg:6
media-libs/libglvnd
media-libs/libpng:=
- >=media-libs/libsdl2-2.28.5[haptic,joystick]
+ media-libs/libsdl2[haptic,joystick]
media-libs/libwebp:=
media-video/ffmpeg:=
net-libs/libpcap
@@ -64,7 +64,7 @@ DEPEND="
x11-base/xorg-proto
"
BDEPEND="
- >=dev-qt/qttools-6.6.0:6[linguist]
+ dev-qt/qttools:6[linguist]
wayland? (
dev-util/wayland-scanner
kde-frameworks/extra-cmake-modules
@@ -84,6 +84,12 @@ src_prepare() {
sed -e '/set(PCSX2_GIT_TAG "")/s/""/"v'${PV}'"/' \
-i cmake/Pcsx2Utils.cmake || die
fi
+
+ # relax Qt6 and SDL2 version requirements which often get restricted
+ # without a specific need, please report a bug to Gentoo (not upstream)
+ # if a still-available older version is really causing issues
+ sed -e '/find_package(\(Qt6\|SDL2\)/s/ [0-9.]*//' \
+ -i cmake/SearchForStuff.cmake || die
}
src_configure() {