summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-26 17:41:34 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-26 17:42:10 -0500
commit449714b8e70c2c99b682839b33ffc8ad285def01 (patch)
tree96f73e529f4dca74daed195874922f649927978e /games-engines
parentgames-engines/zoom: remove deprecated games eclass (diff)
downloadgentoo-449714b8e70c2c99b682839b33ffc8ad285def01.tar.gz
gentoo-449714b8e70c2c99b682839b33ffc8ad285def01.tar.bz2
gentoo-449714b8e70c2c99b682839b33ffc8ad285def01.zip
games-engines/xzip: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.2
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/xzip/xzip-1.8.2-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-engines/xzip/xzip-1.8.2-r3.ebuild b/games-engines/xzip/xzip-1.8.2-r3.ebuild
new file mode 100644
index 000000000000..1de891de0db6
--- /dev/null
+++ b/games-engines/xzip/xzip-1.8.2-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="X interface to Z-code based text games"
+HOMEPAGE="http://www.eblong.com/zarf/xzip.html"
+SRC_URI="http://www.eblong.com/zarf/ftp/xzip182.tar.Z"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/xzip"
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} -DAUTO_END_MODE" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xzip
+ dodoc README
+ doman xzip.1
+}