summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2021-07-26 23:09:45 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-07-28 17:59:29 -0400
commit2b0e3182b7897511cae59444723299092d5d9c2a (patch)
treec91aeb2b69428d75174f26737d409700248bdf94 /games-puzzle/tanglet/tanglet-1.6.1.1.ebuild
parentx11-misc/slim: remove unused patch (diff)
downloadgentoo-2b0e3182b7897511cae59444723299092d5d9c2a.tar.gz
gentoo-2b0e3182b7897511cae59444723299092d5d9c2a.tar.bz2
gentoo-2b0e3182b7897511cae59444723299092d5d9c2a.zip
games-puzzle/tanglet: bump to 1.6.1.1 fixing build with >=qt*-5.14
Dropping the patch since - the first part does not respect ${EPREFIX} and can be replaced with an environment variable in the ebuild - the other parts are obsolete Closes: https://bugs.gentoo.org/704360 Closes: https://bugs.gentoo.org/804570 Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Closes: https://github.com/gentoo/gentoo/pull/21800 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle/tanglet/tanglet-1.6.1.1.ebuild')
-rw-r--r--games-puzzle/tanglet/tanglet-1.6.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-puzzle/tanglet/tanglet-1.6.1.1.ebuild b/games-puzzle/tanglet/tanglet-1.6.1.1.ebuild
new file mode 100644
index 000000000000..65f7fae82093
--- /dev/null
+++ b/games-puzzle/tanglet/tanglet-1.6.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Single player word finding game based on Boggle"
+HOMEPAGE="https://gottcode.org/tanglet/"
+SRC_URI="https://gottcode.org/tanglet/tanglet-1.6.1.1-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" tanglet.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}