summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-08-17 23:56:18 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-08-17 23:59:34 +0100
commit95d699746eb43cc79aa51c241596e59998a153ad (patch)
treee1f6765b20be4ea72c5abc0273276baeef4b931b /games-puzzle
parentgames-puzzle/magiccube4d: Version bump to 4.3.343 (diff)
downloadgentoo-95d699746eb43cc79aa51c241596e59998a153ad.tar.gz
gentoo-95d699746eb43cc79aa51c241596e59998a153ad.tar.bz2
gentoo-95d699746eb43cc79aa51c241596e59998a153ad.zip
games-puzzle/magiccube4d: Drop old 2.2-r1
Closes: https://bugs.gentoo.org/899008 Closes: https://bugs.gentoo.org/921536 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/magiccube4d/Manifest2
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch53
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch22
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch15
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch11
-rw-r--r--games-puzzle/magiccube4d/magiccube4d-2.2-r1.ebuild44
6 files changed, 0 insertions, 147 deletions
diff --git a/games-puzzle/magiccube4d/Manifest b/games-puzzle/magiccube4d/Manifest
index b521087ebdbb..f79c7334f9d1 100644
--- a/games-puzzle/magiccube4d/Manifest
+++ b/games-puzzle/magiccube4d/Manifest
@@ -1,3 +1 @@
DIST magiccube4d-4.3.343.tar.gz 871676 BLAKE2B a023ef1c84546e32f0de032f3c8515fca8568fa8e22869446a480e878574064b8e5572d2a0e76ae88af06de4f18a911f36e478e9f3c3dc1979915c0aa58d64a3 SHA512 f9fc93d54d850495e9216aa0bbf8beffa662032921e9fef54de9940fc07ad03e9af52d9a488445e4985ec2369abe90494657e6f5e199ebc2070c707dd95cc486
-DIST magiccube4d.gif 20739 BLAKE2B feaf1911e483bff7244476000c75b34794911fe279772b8f5d46ee8bd4125881fb71aaab0ebac891fd0a5db38b746c940991bf5fe9e1ad8a678240b2d6cddf82 SHA512 7a8902710eaa78a6580f024a86bfa1828870dc873a4fef30a7d4fa197a67cd1dde162d6d1d1ba0bea4307c13198d52505fb1a1fa3f6d10b3914af42d7c0ebd49
-DIST mc4d-src-2_2.tgz 144645 BLAKE2B 5b29963d056961ce425f7644b14c35e44ce94bc7be6ea5f3fbbb4048478366951005eb8e91fe7cb12e6f1424ad55add31493e0ad3a4ab18eea9e747f940c35f3 SHA512 19491460bada93b4ee2010004128279cb88ab866a5a8c791080d59fa86e5bacf966d7dab0c9b3074e94b77611ae341480d19b384079e83df549ef25e592b12a6
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch b/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch
deleted file mode 100644
index 7fbd52871887..000000000000
--- a/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -Nru magiccube4d-src-2_2.orig/EventHandler.cpp magiccube4d-src-2_2/EventHandler.cpp
---- magiccube4d-src-2_2.orig/EventHandler.cpp 2007-09-30 12:01:46.503967712 +0200
-+++ magiccube4d-src-2_2/EventHandler.cpp 2007-09-30 12:03:23.489172011 +0200
-@@ -20,6 +20,7 @@
- #include <iostream>
- #include <unistd.h>
- #include <stdio.h>
-+#include <stdint.h>
-
- #include "MagicCube.h"
- #include "Puzzlest.h"
-@@ -415,7 +416,7 @@
- void
- EventHandler::undo_cb(void* argp)
- {
-- int arg = (int) argp;
-+ int arg = (intptr_t) argp;
- struct stickerspec grip;
- int dir;
- int slicesmask;
-@@ -461,7 +462,7 @@
- void
- EventHandler::redo_cb(void* argp)
- {
-- int arg = (int) argp;
-+ int arg = (intptr_t) argp;
- struct stickerspec grip;
- int dir;
- int slicesmask;
-@@ -507,7 +508,7 @@
- void
- EventHandler::scramble_cb(void *arg = NULL)
- {
-- int n = (int)arg;
-+ int n = (intptr_t)arg;
- struct stickerspec grip;
- int i, previous_face = -1;
- int ngrips = NFACES * 3 * 3 * 3;
-@@ -855,12 +856,12 @@
- void
- EventHandler::newPuzzle_cb(void* arg)
- {
-- if ((int)arg == preferences.getLength())
-+ if ((intptr_t)arg == preferences.getLength())
- {
- reset_cb(0);
- return;
- }
-- preferences.setLength((int)arg);
-+ preferences.setLength((intptr_t)arg);
- int length = preferences.getLength();
-
- polymgr->reset(length);
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch b/games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch
deleted file mode 100644
index 8e2aaf2b5fcd..000000000000
--- a/games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/EventHandler.h.old 2006-05-19 22:11:48.000000000 +0200
-+++ b/EventHandler.h 2006-05-19 22:11:58.000000000 +0200
-@@ -165,7 +165,7 @@
-
- int number_of_reference_stickers_needed;
- int (*reference_stickers_needed)[4];
-- void (EventHandler::*what_to_do_after_got_reference_stickers) (void *arg = NULL);
-+ void (EventHandler::*what_to_do_after_got_reference_stickers) (void *arg);
- void* cur_ui_data;
-
- bool quick_mode;
---- a/Machine.h.old 2006-05-19 22:12:17.000000000 +0200
-+++ b/Machine.h 2006-05-19 22:12:29.000000000 +0200
-@@ -31,7 +31,7 @@
- {
- public:
- typedef void (EventHandler::*event_handler)(EventHandler::Event*,
-- void *arg = 0);
-+ void *arg);
- virtual ~Machine() {};
-
- static Machine* createMachine(EventHandler*, int& argc, char *argv[],
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch b/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch
deleted file mode 100644
index 73d1b4a59dca..000000000000
--- a/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/Makefile.in.old 2010-10-15 10:38:48.000000000 +0200
-+++ b/Makefile.in 2010-10-15 10:39:07.000000000 +0200
-@@ -72,10 +72,10 @@
- $(CXX) -c $(CXXFLAGS) $<
-
- $(TARGET): $(OBJS)
-- $(CXX) -o $(TARGET) $(OBJS) $(LIBDIRS) $(LIBS)
-+ $(CXX) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBDIRS) $(LIBS)
-
- $(TARGET).static: $(OBJS)
-- $(CXX) -static -o $(TARGET).static $(OBJS) $(LIBDIRS) $(LIBS)
-+ $(CXX) $(LDFLAGS) -static -o $(TARGET).static $(OBJS) $(LIBDIRS) $(LIBS)
-
- Vec.h: vec_h.c
- $(CC) -o vec_h vec_h.c
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch b/games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch
deleted file mode 100644
index d242438d8d05..000000000000
--- a/games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/EventHandler.cpp.old 2004-11-04 22:58:13.735812448 +1100
-+++ b/EventHandler.cpp 2004-11-04 22:57:03.176539088 +1100
-@@ -326,7 +326,7 @@
- number_of_reference_stickers_needed--;
- reference_stickers_needed++;
- if (number_of_reference_stickers_needed == 0)
-- (this->*what_to_do_after_got_reference_stickers)();
-+ (this->*what_to_do_after_got_reference_stickers)(NULL);
- }
- }
-
diff --git a/games-puzzle/magiccube4d/magiccube4d-2.2-r1.ebuild b/games-puzzle/magiccube4d/magiccube4d-2.2-r1.ebuild
deleted file mode 100644
index 1c45efaeaffc..000000000000
--- a/games-puzzle/magiccube4d/magiccube4d-2.2-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit desktop
-
-MY_PV="${PV/./_}"
-DESCRIPTION="Four-dimensional analog of Rubik's cube"
-HOMEPAGE="https://www.superliminal.com/cube/cube.htm"
-SRC_URI="https://www.superliminal.com/cube/mc4d-src-${MY_PV}.tgz
- https://superliminal.com/cube/cube_transp.gif -> ${PN}.gif"
-
-LICENSE="free-noncomm"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="x11-libs/libXaw"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}-src-${MY_PV}"
-
-src_prepare() {
- default
- eapply "${FILESDIR}"/${PN}-EventHandler.patch \
- "${FILESDIR}/${P}"-gcc41.patch \
- "${FILESDIR}/${P}"-64bit-ptr.patch \
- "${FILESDIR}"/${P}-ldflags.patch
- sed -i \
- -e "s:-Werror::" \
- configure \
- || die "sed failed"
-}
-
-src_compile() {
- emake DFLAGS="${CFLAGS}"
-}
-
-src_install() {
- dobin magiccube4d
- dodoc ChangeLog MagicCube4D-unix.txt readme-unix.txt Intro.txt
- doicon "${DISTDIR}"/${PN}.gif
- make_desktop_entry ${PN} "Magic Cube 4D" /usr/share/pixmaps/${PN}.gif
-}