summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-roguelike/tome
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-roguelike/tome')
-rw-r--r--games-roguelike/tome/Manifest1
-rw-r--r--games-roguelike/tome/files/2.3.5-gentoo-paths.patch31
-rw-r--r--games-roguelike/tome/files/tome-2.3.5-noX.patch11
-rw-r--r--games-roguelike/tome/metadata.xml5
-rw-r--r--games-roguelike/tome/tome-2.3.5.ebuild124
5 files changed, 172 insertions, 0 deletions
diff --git a/games-roguelike/tome/Manifest b/games-roguelike/tome/Manifest
new file mode 100644
index 000000000000..ad7e69b29de7
--- /dev/null
+++ b/games-roguelike/tome/Manifest
@@ -0,0 +1 @@
+DIST tome-235-src.tar.bz2 2951227 SHA256 8844b0b889bac3943ea2f4d4d43b38e2d91d242a93028e9e07403aaab46d691b SHA512 f456aa91d18397297c213fa67dd14a4d29e024525be99f83b22cbe42f4d426b57fe6115a7124e3ec34de8f351117de525eab996ba7a2a230119e43639c4c9205 WHIRLPOOL 87628c68051ef2a063dc03f261110a010cf48a9fe0ef0e6feb1622b87263a8b9fa5a7d580201faf9e923196a2015d636659835cf2686a774332352cd233b66cb
diff --git a/games-roguelike/tome/files/2.3.5-gentoo-paths.patch b/games-roguelike/tome/files/2.3.5-gentoo-paths.patch
new file mode 100644
index 000000000000..d171a1cf540f
--- /dev/null
+++ b/games-roguelike/tome/files/2.3.5-gentoo-paths.patch
@@ -0,0 +1,31 @@
+diff -rU 1 tome-225-src.orig/src/files.c tome-225-src/src/files.c
+--- tome-225-src.orig/src/files.c 2004-01-14 11:17:02.423263360 -0500
++++ tome-225-src/src/files.c 2004-01-14 11:17:50.074019344 -0500
+@@ -5670,3 +5670,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -5748,3 +5748,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -5846,3 +5846,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -6296,3 +6296,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+diff -rU 1 tome-225-src.orig/src/init2.c tome-225-src/src/init2.c
+--- tome-225-src.orig/src/init2.c 2004-01-14 11:17:02.473255760 -0500
++++ tome-225-src/src/init2.c 2004-01-14 11:17:58.286770816 -0500
+@@ -6686,3 +6686,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
diff --git a/games-roguelike/tome/files/tome-2.3.5-noX.patch b/games-roguelike/tome/files/tome-2.3.5-noX.patch
new file mode 100644
index 000000000000..5c5982fe730d
--- /dev/null
+++ b/games-roguelike/tome/files/tome-2.3.5-noX.patch
@@ -0,0 +1,11 @@
+--- makefile.old 2012-05-28 14:02:44.787705444 +0200
++++ makefile 2012-05-28 14:03:44.520524011 +0200
+@@ -458,7 +458,7 @@
+ $(CC) $(PROFILELDFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ $(TOLUA): $(TOLUAOBJS) lua/tolua.c lua/tolualua.c
+- $(CC) $(CFLAGS) $(PROFILELDFLAGS) $(LDFLAGS) -o $@ $(TOLUAOBJS) lua/tolua.c lua/tolualua.c $(LIBS)
++ $(CC) $(CFLAGS) $(PROFILELDFLAGS) $(LDFLAGS) -o $@ $(TOLUAOBJS) lua/tolua.c lua/tolualua.c
+
+ #
+ # An install rule.
diff --git a/games-roguelike/tome/metadata.xml b/games-roguelike/tome/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-roguelike/tome/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-roguelike/tome/tome-2.3.5.ebuild b/games-roguelike/tome/tome-2.3.5.ebuild
new file mode 100644
index 000000000000..fce8c6f64d18
--- /dev/null
+++ b/games-roguelike/tome/tome-2.3.5.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_PV=${PV//./}
+DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
+HOMEPAGE="http://t-o-m-e.net/"
+SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tar.bz2"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="X Xaw3d gtk sdl"
+
+RDEPEND=">=sys-libs/ncurses-5
+ X? ( x11-libs/libX11 )
+ Xaw3d? ( x11-libs/libXaw )
+ sdl? (
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/libsdl )
+ gtk? ( >=x11-libs/gtk+-2.12.8:2 ) "
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-misc/makedepend"
+
+S=${WORKDIR}/tome-${MY_PV}-src/src
+
+src_prepare() {
+ mv makefile.std makefile
+ epatch "${FILESDIR}/${PV}-gentoo-paths.patch" \
+ "${FILESDIR}"/${P}-noX.patch
+ sed -i -e '/^CC =/d' makefile || die
+ sed -i -e "s:xx:x:" ../lib/edit/p_info.txt || die
+ sed -i -e "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c || die
+
+ find .. -name .cvsignore -exec rm -f \{\} +
+ find ../lib/edit -type f -exec chmod a-x \{\} +
+}
+
+src_compile() {
+ local GENTOO_INCLUDES="" GENTOO_DEFINES="-DUSE_GCU " GENTOO_LIBS="$(pkg-config ncurses --libs)"
+ if use sdl || use X || use gtk || use Xaw3d; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_EGO_GRAPHICS -DUSE_TRANSPARENCY \
+ -DSUPPORT_GAMMA"
+ fi
+ if use sdl || use X || use Xaw3d; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_PRECISE_CMOVIE -DUSE_UNIXSOCK "
+ fi
+ if use sdl; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} $(sdl-config --cflags)"
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_SDL "
+ GENTOO_LIBS="${GENTOO_LIBS} $(sdl-config --libs) -lSDL_image -lSDL_ttf"
+ fi
+ if use X; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_X11 "
+ GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lX11 "
+ fi
+ if use Xaw3d; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_XAW "
+ GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lXaw -lXmu -lXt -lX11 "
+ fi
+ if use gtk; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} $(pkg-config gtk+-2.0 --cflags)"
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_GTK2 "
+ GENTOO_LIBS="${GENTOO_LIBS} $(pkg-config gtk+-2.0 --libs) "
+ GTK_SRC_FILE="main-gtk2.c"
+ GTK_OBJ_FILE="main-gtk2.o"
+ else
+ GTK_SRC_FILE=""
+ GTK_OBJ_FILE=""
+ fi
+ if use amd64; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DLUA_NUM_TYPE=int "
+ fi
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -Ilua -I."
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_LUA"
+ emake -j1 \
+ INCLUDES="${GENTOO_INCLUDES}" \
+ DEFINES="${GENTOO_DEFINES}" \
+ depend
+ emake ./tolua
+ emake \
+ COPTS="${CFLAGS}" \
+ INCLUDES="${GENTOO_INCLUDES}" \
+ DEFINES="${GENTOO_DEFINES}" \
+ LIBS="${GENTOO_LIBS} -lm" \
+ BINDIR="${GAMES_BINDIR}" \
+ LIBDIR="${GAMES_DATADIR}/${PN}" \
+ GTK_SRC_FILE="${GTK_SRC_FILE}" \
+ GTK_OBJ_FILE="${GTK_OBJ_FILE}"
+}
+
+src_install() {
+ emake -j1 \
+ DESTDIR="${D}" \
+ OWNER="${GAMES_USER}" \
+ BINDIR="${GAMES_BINDIR}" \
+ LIBDIR="${GAMES_DATADIR}/${PN}" install
+ cd ..
+ dodoc *.txt
+
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}/${GAMES_STATEDIR}/${PN}-scores.raw"
+ prepgamesdirs
+ fperms g+w "${GAMES_STATEDIR}/${PN}-scores.raw"
+ #FIXME: something has to be done about this.
+ fperms g+w "${GAMES_DATADIR}/${PN}/data"
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "ToME ${PV} is not save-game compatible with 2.3.0 and previous versions."
+ echo
+ ewarn "If you have older save files and you wish to continue those games,"
+ ewarn "you'll need to remerge the version of ToME with which you started"
+ ewarn "those save-games."
+}