summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-08-09 16:04:25 +0200
committerJames Le Cuirot <chewi@gentoo.org>2024-08-15 22:09:51 +0100
commit6c302b8235d7277db0f8687f0da88abeadbb9bca (patch)
tree4dfb646004c185acb53bf13e49ba4e2c75b197a6 /games-roguelike
parentwww-servers/nginx: fix for CVE-2024-7347 (diff)
downloadgentoo-6c302b8235d7277db0f8687f0da88abeadbb9bca.tar.gz
gentoo-6c302b8235d7277db0f8687f0da88abeadbb9bca.tar.bz2
gentoo-6c302b8235d7277db0f8687f0da88abeadbb9bca.zip
games-roguelike/moria: add 5.7.15
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/38029 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/moria/Manifest1
-rw-r--r--games-roguelike/moria/moria-5.7.15.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/games-roguelike/moria/Manifest b/games-roguelike/moria/Manifest
index 88300d04f1e7..99f7c68dbb0a 100644
--- a/games-roguelike/moria/Manifest
+++ b/games-roguelike/moria/Manifest
@@ -1 +1,2 @@
DIST moria-5.7.14.tar.gz 395191 BLAKE2B dfa8481c51009fba3d692d8f5a667a85904149a7756822b435ae8fe30a8ad9c5bb901f6efb21dfe17e1155e49c080ca7b3de154bcd2a5df055a17b3a81b5b6b0 SHA512 5c99ed314a29684d2fc18a1429fb7609553a78fd053eac8d61189e0af8c72777d481910153514dfe544a8939be24ed9725fc2b31e89e5d6e26f0b1df5ad4c3e0
+DIST moria-5.7.15.tar.gz 400424 BLAKE2B 779eaeb50eb2c0310beb1a02ebae355dadecfa29d519f8614e602172d3969d939abf9b86e0809f813b944eb72abaecb28e730ef9259a648c1dad179a6e8e4f96 SHA512 9ef9723eb120e5180640d8aa52073df638e506e0c842dac7173643bebfd84c51ec1fe6e2b1fa84ad1dcef29dc6607639e6a19ac4fd47000c6ba241691c1c720c
diff --git a/games-roguelike/moria/moria-5.7.15.ebuild b/games-roguelike/moria/moria-5.7.15.ebuild
new file mode 100644
index 000000000000..9b36761da632
--- /dev/null
+++ b/games-roguelike/moria/moria-5.7.15.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_IN_SOURCE_BUILD="yes"
+inherit cmake prefix
+
+DESCRIPTION="The Dungeons of Moria, a single player roguelike game, also known as Umoria"
+HOMEPAGE="https://umoria.org/"
+SRC_URI="https://github.com/dungeons-of-moria/umoria/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/umoria-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~m68k ~x86"
+
+RDEPEND="acct-group/gamestat
+ >=sys-libs/ncurses-6.0:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-5.7.12-gentoo-paths.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+ hprefixify src/config.cpp
+}
+
+src_install() {
+ newbin umoria/umoria moria
+
+ insinto /usr/share/moria
+ doins umoria/data/*.txt
+
+ insinto /var/lib/moria
+ doins umoria/scores.dat
+ fowners root:gamestat /var/lib/moria/scores.dat /usr/bin/${PN}
+ fperms g+w /var/lib/moria/scores.dat
+
+ doman "${FILESDIR}"/${PN}.6
+ dodoc -r AUTHORS CHANGELOG.md CONTRIBUTING.md README.md historical
+}
+
+pkg_postinst() {
+ elog
+ elog "Please add users to the 'gamestat' group, so they can run Moria:"
+ elog " usermod -aG gamestat <user>"
+ elog
+}