summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-09-08 21:12:12 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-09-08 21:12:12 +0100
commit67d73a73ea213fb5723dd58053ffc84e65eaab01 (patch)
tree10e7ec82d43901945624916ea385ba54dea269fb /games-rpg/broken-age/broken-age-2.4.800398.ebuild
parentprofiles: Mask games-rpg/broken-age in non-glibc/multilib profiles (diff)
downloadgentoo-67d73a73ea213fb5723dd58053ffc84e65eaab01.tar.gz
gentoo-67d73a73ea213fb5723dd58053ffc84e65eaab01.tar.bz2
gentoo-67d73a73ea213fb5723dd58053ffc84e65eaab01.zip
games-rpg/broken-age: New package
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-rpg/broken-age/broken-age-2.4.800398.ebuild')
-rw-r--r--games-rpg/broken-age/broken-age-2.4.800398.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-rpg/broken-age/broken-age-2.4.800398.ebuild b/games-rpg/broken-age/broken-age-2.4.800398.ebuild
new file mode 100644
index 000000000000..fed3b2fba16a
--- /dev/null
+++ b/games-rpg/broken-age/broken-age-2.4.800398.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop xdg
+
+MY_PN="BrokenAge"
+DESCRIPTION="A point-and-click adventure from Tim Schafer's Double Fine Productions"
+HOMEPAGE="http://www.brokenagegame.com"
+SRC_URI="${MY_PN}_linux.tar.gz"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ media-libs/libsdl2[abi_x86_32,joystick,opengl,sound,video]
+ virtual/opengl[abi_x86_32]
+"
+
+S="${WORKDIR}"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe ${MY_PN}
+ make_wrapper ${PN} ./${MY_PN} "${DIR}"
+
+ insinto "${DIR}"
+ doins *.pck
+
+ exeinto "${DIR}"/lib
+ doexe lib/libfmod*.so
+
+ make_desktop_entry ${PN} "Broken Age" applications-games
+ dodoc ReadMe.txt
+}