summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/nwmovies
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/nwmovies')
-rw-r--r--games-rpg/nwmovies/Manifest1
-rw-r--r--games-rpg/nwmovies/metadata.xml9
-rw-r--r--games-rpg/nwmovies/nwmovies-20090223.080954.ebuild55
3 files changed, 65 insertions, 0 deletions
diff --git a/games-rpg/nwmovies/Manifest b/games-rpg/nwmovies/Manifest
new file mode 100644
index 000000000000..3d0d3ee5897a
--- /dev/null
+++ b/games-rpg/nwmovies/Manifest
@@ -0,0 +1 @@
+DIST nwmovies-v4-public.20090223.080954.tar.gz 137697 SHA256 4ce60791183a0623d09b37c9f00ba42a2f7e7d953eba35b090a96cc891254f14 SHA512 35b3697f593e74e2c507c745f5b03da11c65789d2cb6378988bb5f810c1768af7299bd0dd8197a91c928f4438582107300bad8de8d69ede8cb81200ea5d21f0e WHIRLPOOL 896c935ea9b8a8eb6befec4c99406763c17e33aa5b767d20dab7f46938e9009e202f6d1afb5d25e7f4ceec628a50be7e0fcf87d823d06d4e1163f46dfb763bb9
diff --git a/games-rpg/nwmovies/metadata.xml b/games-rpg/nwmovies/metadata.xml
new file mode 100644
index 000000000000..0a7563a794f3
--- /dev/null
+++ b/games-rpg/nwmovies/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>calchan@gentoo.org</email>
+ <name>Denis Dupeyron</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-rpg/nwmovies/nwmovies-20090223.080954.ebuild b/games-rpg/nwmovies/nwmovies-20090223.080954.ebuild
new file mode 100644
index 000000000000..a875545fa637
--- /dev/null
+++ b/games-rpg/nwmovies/nwmovies-20090223.080954.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Play Neverwinter Nights movies inside the Linux client"
+HOMEPAGE="http://home.roadrunner.com/~nwmovies/"
+
+SRC_URI="${HOMEPAGE}/${PN}/${PN}-v4-public.${PV}.tar.gz"
+
+LICENSE="nwmovies Artistic"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=games-rpg/nwn-data-1.29-r3[videos]"
+RDEPEND="${DEPEND}
+ >=games-rpg/nwn-1.68-r4
+ media-video/binkplayer"
+
+S="${WORKDIR}"
+DESTDIR="${GAMES_PREFIX_OPT}/nwn"
+
+QA_TEXTRELS="opt/nwn/nwmovies/binklib.so opt/nwn/nwmovies.so"
+QA_WX_LOAD="opt/nwn/nwmovies.so"
+QA_EXECSTACK="opt/nwn/nwmovies.so"
+QA_FLAGS_IGNORED="opt/nwn/nwmovies/binklib.so opt/nwn/nwmovies/libdis/libdisasm.so opt/nwn/nwmovies.so"
+
+src_install() {
+ exeinto "${DESTDIR}"
+ doexe nwmovies.so nwmovies.pl || die "Installation failed"
+ exeinto "${DESTDIR}/nwmovies"
+ doexe nwmovies/binklib.so || die "Installation failed"
+ exeinto "${DESTDIR}/nwmovies/libdis"
+ doexe nwmovies/libdis/libdisasm.so || die "Installation failed"
+ insinto "${DESTDIR}"
+ doins nwmovies/*.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "When starting nwn the next time, nwmovies will scan the nwmain"
+ elog "binary for its hooks, store this information in:"
+ elog " \${HOME}/.nwn/\${LANG}/nwmovies.ini"
+ elog "and exit. This is normal."
+ elog
+ elog "You will have to remove this file whenever you update nwn."
+ elog
+ elog "If you have sound issues in NWN only when using nwmovies, then"
+ elog "you may need to properly setup /etc/asound.conf or the equivalent"
+ elog "per-user \${HOME}/.asound.conf, see comment #31 in bug #106789."
+}