summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-19 14:02:17 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-19 16:32:05 +0100
commita1f836436c19a8afdcdaa62864b716d0e04e65c2 (patch)
treeeffb1e53343a93f8d7346423c77d57c0c56399f7 /games-strategy
parentgames-strategy/war1gus: Bump to 3.0.0 (diff)
downloadgentoo-a1f836436c19a8afdcdaa62864b716d0e04e65c2.tar.gz
gentoo-a1f836436c19a8afdcdaa62864b716d0e04e65c2.tar.bz2
gentoo-a1f836436c19a8afdcdaa62864b716d0e04e65c2.zip
games-strategy/wargus: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wargus/Manifest1
-rw-r--r--games-strategy/wargus/wargus-3.0.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/games-strategy/wargus/Manifest b/games-strategy/wargus/Manifest
index 75a106a3ee0a..2a1683db4750 100644
--- a/games-strategy/wargus/Manifest
+++ b/games-strategy/wargus/Manifest
@@ -1,2 +1,3 @@
DIST wargus-2.4.1.tar.gz 45981981 BLAKE2B 8d80e5d781a1be1edf602f13d77b84e85fe2592fb0a784f1b25b5c9656eaf10a11c3241dfa71388c9a01a9e8fad15b1805a67ddb3157c2a0e86d967f3852869a SHA512 d468d9ad08907fbbfd02af0bca069d6a95d5303cd4f3d838c12bbfe6af0d48f695f9f49d446dbddeae2a91deb1eaa17875954eefdfbe5e25cd840c4454dc6ea0
DIST wargus-2.4.3.tar.gz 46635465 BLAKE2B be559e6efdba7542e9ed65f4ece5419b781b61d7d6d43b40418ca8dffc446fa7478f608d7f24696281c7acbda4dc5bf8d808feeb3376ae3e8a04b3372d18ace1 SHA512 0c9eca898146c44e211e0da7061cb605eb04ab113fd9ad0c51f9b92df8724a5b28aea9b7cf9bfadd44f0183f8b5c519d7da0050b260624f4f7da4b9f8aee458c
+DIST wargus-3.0.0.tar.gz 4890178 BLAKE2B 7ab4a4b5e8171b2297e17f0338a5fd674cff7beb3457e33c7938c12f9a262d81b9faf2db6ae00fdbbef440624880c37bfe61c2b9957e943cf13d364544f58a65 SHA512 70bf6a5a3d489c9d88bf28e65eea85936ac42850b9c8f27c5cb4a7ba8ff28c609274235c735abb4de92e5c63113d4850adc1da313ff39cbdee797de6b9e1cc43
diff --git a/games-strategy/wargus/wargus-3.0.0.ebuild b/games-strategy/wargus/wargus-3.0.0.ebuild
new file mode 100644
index 000000000000..23954b3347a3
--- /dev/null
+++ b/games-strategy/wargus/wargus-3.0.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Warcraft II for the Stratagus game engine"
+HOMEPAGE="https://wargus.github.io/
+ https://github.com/Wargus/wargus"
+SRC_URI="https://github.com/Wargus/wargus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ =games-engines/stratagus-${PV}*[theora]
+ media-libs/libpng:0=
+ sys-libs/zlib:=
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ !games-strategy/wargus-data"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ if has_version games-strategy/wargus-data; then
+ ewarn "The system-wide install of game data via games-strategy/wargus-data"
+ ewarn "no longer works. The old data will be uninstalled after merging"
+ ewarn "this version of Wargus. If you would like to preserve it, please"
+ ewarn "abort the process and back /usr/share/stratagus/wargus up."
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DGAMEDIR="${EPREFIX}/usr/bin"
+ -DBINDIR="${EPREFIX}/usr/bin"
+ -DSTRATAGUS="${EPREFIX}/usr/bin/stratagus"
+ -DSHAREDIR="${EPREFIX}/usr/share/stratagus/wargus"
+ -DICONDIR=/usr/share/icons/hicolor/64x64/apps
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "Wargus requires the data from the original game to run. The game"
+ elog "will ask you for the location of the game data and extract/convert"
+ elog "it automatically on the first run. Only the DOS version is supported"
+ elog "at the moment."
+
+ if ! has_version media-video/ffmpeg ||
+ ! has_version media-sound/cdparanoia
+ then
+ elog
+ elog "If you did not convert the game data yet, you may want to install"
+ elog "the following optional dependencies:"
+ elog
+ elog "media-video/ffmpeg -- to convert game videos"
+ elog "media-sound/cdparanoia -- to rip game music from the CD"
+ fi
+
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}