summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/wxchtdecoder
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/wxchtdecoder')
-rw-r--r--games-util/wxchtdecoder/Manifest1
-rw-r--r--games-util/wxchtdecoder/metadata.xml5
-rw-r--r--games-util/wxchtdecoder/wxchtdecoder-1.5a.ebuild28
3 files changed, 34 insertions, 0 deletions
diff --git a/games-util/wxchtdecoder/Manifest b/games-util/wxchtdecoder/Manifest
new file mode 100644
index 000000000000..b1003ea275c1
--- /dev/null
+++ b/games-util/wxchtdecoder/Manifest
@@ -0,0 +1 @@
+DIST wxchtdecoder-1.5a.tar.bz2 84088 SHA256 8f2c0307ffbc103a70a2566ec56bfc4766714118c4d408b18486b950dc2a209e SHA512 edb606d1b88cedcb725a1dca2c82f4a81ebff5a1b8786a4127505e021b1fc8cc351363d05963a68c7d555f895b3b762fbd34dfc3f26640759619daecce1097df WHIRLPOOL a49ce993e228a8c3c9dfdeb5f0a1e148aecef71cf736d069ef0c3446b443e2f2b28d072511e8b7d4c8cc7fec54f6c061aca4edf849670348a9f15af17e30e3a0
diff --git a/games-util/wxchtdecoder/metadata.xml b/games-util/wxchtdecoder/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-util/wxchtdecoder/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-util/wxchtdecoder/wxchtdecoder-1.5a.ebuild b/games-util/wxchtdecoder/wxchtdecoder-1.5a.ebuild
new file mode 100644
index 000000000000..b084ba9eb533
--- /dev/null
+++ b/games-util/wxchtdecoder/wxchtdecoder-1.5a.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="2.8"
+inherit wxwidgets
+
+DESCRIPTION="A program to decode .CHT files in Snes9x and ZSNES to plain text"
+HOMEPAGE="http://games.technoplaza.net/chtdecoder/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="x11-libs/wxGTK:2.8[X]"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ econf --with-wx-config=${WX_CONFIG}
+}
+
+src_install() {
+ dobin source/wxchtdecoder
+ dodoc docs/wxchtdecoder.txt
+}