summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-08-12 19:09:59 +0200
committerJames Le Cuirot <chewi@gentoo.org>2024-08-14 23:24:37 +0100
commit312ae824abd13cc27e9067eb1d4c2d4a9ae61f63 (patch)
treef1a06d1da5c1c5062556ca12f5e9de391022dce3 /games-util
parentsys-auth/microsoft-identity-broker: Drop old 2.0.0 (diff)
downloadgentoo-312ae824abd13cc27e9067eb1d4c2d4a9ae61f63.tar.gz
gentoo-312ae824abd13cc27e9067eb1d4c2d4a9ae61f63.tar.bz2
gentoo-312ae824abd13cc27e9067eb1d4c2d4a9ae61f63.zip
games-util/acc: add 1.60
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/acc/Manifest1
-rw-r--r--games-util/acc/acc-1.60.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/games-util/acc/Manifest b/games-util/acc/Manifest
index 903051f78c36..e10340c6227c 100644
--- a/games-util/acc/Manifest
+++ b/games-util/acc/Manifest
@@ -1 +1,2 @@
DIST acc-1.58.tar.gz 70326 BLAKE2B 327449b987b2675c4c16f0769c08f2093a0ee2db28e6fbba608f3de81a17d943f6dbfc6ed333ea25331ecf194bdd661d3cfaf0d02b1f5fa714e7f60e49aabca9 SHA512 6fb0302f47b6a4e7114f543ad654f71753fb4cec973c933fc28aa0737f1d68a07509b2eee22cee34422387635cc889882b897a27f782000a2c0b184c1867d650
+DIST acc-1.60.tar.gz 70750 BLAKE2B 57ab6ae8f3a818f4bd3bfb97554e6e04df246f7cfb3f1dc59c7a817cb15000325aa4e4769830d4a1caefa7aa557c803ea1535e58e754adb4438d6858cbf79b99 SHA512 9d44fccd092226ed1c89abf7e13e74a91b05355ea11914768946f81ff74999152cf535ee59eb4c4f9b876100f48cc1d8853daa59add1af59f538bf6b5da84499
diff --git a/games-util/acc/acc-1.60.ebuild b/games-util/acc/acc-1.60.ebuild
new file mode 100644
index 000000000000..ae59620a784b
--- /dev/null
+++ b/games-util/acc/acc-1.60.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ACS script compiler for use with ZDoom and Hexen"
+HOMEPAGE="https://zdoom.org/wiki/ACC"
+SRC_URI="https://github.com/ZDoom/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Activision"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The Activision EULA is inappropriate but this was never resolved. :(
+# https://doomwiki.org/wiki/Raven_source_code_licensing
+RESTRICT="bindist mirror"
+
+src_install() {
+ dobin "${BUILD_DIR}"/${PN}
+ dodoc readme.md
+
+ insinto /usr/share/${PN}
+ doins *.acs
+}