summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-05-22 22:02:42 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-05-22 22:15:04 +0100
commit9626749fe8c6aefaffe0a8b26e966d5765087fcc (patch)
tree9c5606c01b355b22007a72d9cd933211f9d36399 /games-util
parentnet-misc/freerdp: fix patch (diff)
downloadgentoo-9626749fe8c6aefaffe0a8b26e966d5765087fcc.tar.gz
gentoo-9626749fe8c6aefaffe0a8b26e966d5765087fcc.tar.bz2
gentoo-9626749fe8c6aefaffe0a8b26e966d5765087fcc.zip
games-util/lgogdownloader: Bump to 3.13, drop old 3.12-r1
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lgogdownloader/Manifest2
-rw-r--r--games-util/lgogdownloader/files/lgogdownloader-qt6.patch73
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.13.ebuild (renamed from games-util/lgogdownloader/lgogdownloader-3.12-r1.ebuild)4
3 files changed, 1 insertions, 78 deletions
diff --git a/games-util/lgogdownloader/Manifest b/games-util/lgogdownloader/Manifest
index 8eaacb4f0504..eb40c9144019 100644
--- a/games-util/lgogdownloader/Manifest
+++ b/games-util/lgogdownloader/Manifest
@@ -1 +1 @@
-DIST lgogdownloader-3.12.tar.gz 96896 BLAKE2B 27e967c6be6919eda7a0adade72221d7b90e5b328e9a10201afa32046a384488f3c312ed94ff86ce376e7f1b9e99baabc3752a1f9536fdacf4fcc987132253f6 SHA512 04a753f772434cdbc634efd69ccf4007376c789d68b9204947045bafc0f953d8bbfad0104b6ffaad257bd3d1eabcae73e7ee56b65611799ceff6454418dc86b8
+DIST lgogdownloader-3.13.tar.gz 98904 BLAKE2B 11e09a93c34d626d3ed82e99b5b0e855f46d365ca655571955f57acd45d3ecb7e8b6ad666c1f42574291a3499db1428e432c8074c61828ae4c4b13cf1e23f8f2 SHA512 0a936543eec350c5d257c43fa99552428365c1ddba8f0d51d7add27a4fb7a8a2ac823545ff211b9bab4fc64307dd200c9fdff2d412903094a0d2ab46eb20e767
diff --git a/games-util/lgogdownloader/files/lgogdownloader-qt6.patch b/games-util/lgogdownloader/files/lgogdownloader-qt6.patch
deleted file mode 100644
index 5d1652bcbdd7..000000000000
--- a/games-util/lgogdownloader/files/lgogdownloader-qt6.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 3f223684cbe1367c68b2b68301eeaaf644a4c0be Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Thu, 14 Mar 2024 22:12:02 +0000
-Subject: [PATCH] Add support for Qt6 (as well as Qt5)
-
-No actual code changes were necessary.
-
-I have partly followed
-https://doc.qt.io/qt-6/cmake-qt5-and-qt6-compatibility.html, but the
-versionless targets only work from Qt 5.15 onwards. The suggested
-workaround chooses 5 over 6 and does not appear to work properly when
-one of the required components is missing. Using the versionless
-approach with an additional variable for the targets seems to work best.
-
-If necessary, Qt 5 can be forced over 6 by passing
-`-DCMAKE_DISABLE_FIND_PACKAGE_Qt6=ON`.
-
-I have tested this by tweaking the code to force the GUI to appear.
----
- CMakeLists.txt | 20 +++++++++++++++-----
- 1 file changed, 15 insertions(+), 5 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0fe7568..9f489c1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -45,8 +45,12 @@ file(GLOB SRC_FILES
- )
-
- if(USE_QT_GUI)
-- find_package(Qt5Widgets CONFIG REQUIRED)
-- find_package(Qt5WebEngineWidgets CONFIG REQUIRED)
-+ set(QT Qt6)
-+ find_package(Qt6 COMPONENTS Widgets WebEngineWidgets CONFIG)
-+ if(NOT Qt6_FOUND)
-+ set(QT Qt5)
-+ find_package(Qt5 REQUIRED COMPONENTS Widgets WebEngineWidgets CONFIG)
-+ endif()
-
- file(GLOB QT_GUI_SRC_FILES
- src/gui_login.cpp
-@@ -140,11 +144,17 @@ file(REMOVE ${CMAKE_BINARY_DIR}/test_atomic.cpp)
-
- if(USE_QT_GUI)
- target_link_libraries(${PROJECT_NAME}
-- PRIVATE Qt5::Widgets
-- PRIVATE Qt5::WebEngineWidgets
-+ PRIVATE ${QT}::Widgets
-+ PRIVATE ${QT}::WebEngineWidgets
- )
- endif(USE_QT_GUI)
-
-+if(Qt6_FOUND)
-+ set_property(TARGET ${PROJECT_NAME} PROPERTY CXX_STANDARD 17)
-+else()
-+ set_property(TARGET ${PROJECT_NAME} PROPERTY CXX_STANDARD 11)
-+endif(Qt6_FOUND)
-+
- if(MSVC)
- # Force to always compile with W4
- if(CMAKE_CXX_FLAGS MATCHES "/W[0-4]")
-@@ -154,7 +164,7 @@ if(MSVC)
- endif()
- elseif(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID MATCHES "Clang")
- # Update if necessary
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Wextra -Wno-long-long -fexceptions")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wno-long-long -fexceptions")
- endif()
-
- set(INSTALL_BIN_DIR bin CACHE PATH "Installation directory for executables")
---
-2.43.2
-
diff --git a/games-util/lgogdownloader/lgogdownloader-3.12-r1.ebuild b/games-util/lgogdownloader/lgogdownloader-3.13.ebuild
index e07404cb11a4..18c12cef2fca 100644
--- a/games-util/lgogdownloader/lgogdownloader-3.12-r1.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-3.13.ebuild
@@ -36,10 +36,6 @@ BDEPEND="
virtual/pkgconfig
"
-PATCHES=(
- "${FILESDIR}"/${PN}-qt6.patch
-)
-
src_configure() {
local mycmakeargs=(
-DUSE_QT_GUI=$(usex gui)