summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-10-13 14:57:32 +0300
committerMart Raudsepp <leio@gentoo.org>2019-10-13 15:06:02 +0300
commit534f57e75300e19b72f3470d1fb2ec60f971f02b (patch)
treea8488e759dbb8d630991e23892cf1f9a449ed649 /gnome-extra/gnome-characters/gnome-characters-3.32.1.ebuild
parentmedia-video/cheese: bump to 3.32.1 (diff)
downloadgentoo-534f57e75300e19b72f3470d1fb2ec60f971f02b.tar.gz
gentoo-534f57e75300e19b72f3470d1fb2ec60f971f02b.tar.bz2
gentoo-534f57e75300e19b72f3470d1fb2ec60f971f02b.zip
gnome-extra/gnome-characters: bump to 3.32.1
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-characters/gnome-characters-3.32.1.ebuild')
-rw-r--r--gnome-extra/gnome-characters/gnome-characters-3.32.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnome-extra/gnome-characters/gnome-characters-3.32.1.ebuild b/gnome-extra/gnome-characters/gnome-characters-3.32.1.ebuild
new file mode 100644
index 000000000000..c2308713264d
--- /dev/null
+++ b/gnome-extra/gnome-characters/gnome-characters-3.32.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_5,3_6} )
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/CharacterMap"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/gjs-1.50
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.35.9:=
+ >=dev-libs/libunistring-0.9.5
+ >=x11-libs/gtk+-3.20:3[introspection]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/pango-1.36[introspection]
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}