summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-04-23 13:13:18 -0300
committerMatt Turner <mattst88@gentoo.org>2023-04-24 12:41:41 -0400
commit77cd593e5961c9fcde2f70de6dcd0fe6d5a8befa (patch)
treea46fb00149d5d0189392a26853b95748871d40f2 /gnome-extra/gnome-user-docs
parentnet-misc/connman: add 1.42_pre20230411 (diff)
downloadgentoo-77cd593e5961c9fcde2f70de6dcd0fe6d5a8befa.tar.gz
gentoo-77cd593e5961c9fcde2f70de6dcd0fe6d5a8befa.tar.bz2
gentoo-77cd593e5961c9fcde2f70de6dcd0fe6d5a8befa.zip
gnome-extra/gnome-user-docs: Version bump to 44.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30718 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-user-docs')
-rw-r--r--gnome-extra/gnome-user-docs/Manifest1
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-44.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/Manifest b/gnome-extra/gnome-user-docs/Manifest
index e9ec18253490..8943d4e161f7 100644
--- a/gnome-extra/gnome-user-docs/Manifest
+++ b/gnome-extra/gnome-user-docs/Manifest
@@ -1,2 +1,3 @@
DIST gnome-user-docs-43.0.tar.xz 11303880 BLAKE2B c9f3e0757eaa25944198c4c07809a86642e9e879e83856aaa3f8f968b35dc45667768acda0039f1e8a6f9a57e86afbd2d8df5e21d3ab7fa41a5e79cfe0f666eb SHA512 cf14edc34049d8e770f31e34b722a3309009fac64f3ac159cdf2baaebf7bd70ea8f0c592b398c9f0e21e11c7ac10d91a97a0079376da07dd1d433c2d3703eeef
DIST gnome-user-docs-44.0.tar.xz 12570592 BLAKE2B 1acb8a1a46eb85e42d21a45122d01ff85ea7f687e767f2f091b807abab80cfe373fc6dbed2fa1a513a80db2d35d7b066455d5290e3c61fd71e217f91242ea6f2 SHA512 144c5053998594cfa7e80c730b6ef1cd60dcd9dae34756e6116c5ef96d1660d7153e64348dbab4efdd26c073b56c0740f218778de48fa684d37a8a3e57d98d55
+DIST gnome-user-docs-44.1.tar.xz 13297308 BLAKE2B 4e6c15d7511157c677d578804c883b7af3e8961cb9edfc192a51ef5d79020f638759c54d1f4ea26799bd59a8c008cf88e5432e1393ceaa82dfd4e9aab45b8d43 SHA512 9f1351232d09249ec21c9574e4d691e77eabf3840eb41242afeb44243049ffdc3ee3a064ef36962eb5418c4445c23be27675fdd2c1d71c758a3564419a1fd950
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-44.1.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-44.1.ebuild
new file mode 100644
index 000000000000..f5c2e5bd8bf7
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-44.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-libs/libxml2 )"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+ !test? ( test )"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}