summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/zeitgeist-datahub
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/zeitgeist-datahub')
-rw-r--r--gnome-extra/zeitgeist-datahub/Manifest1
-rw-r--r--gnome-extra/zeitgeist-datahub/metadata.xml17
-rw-r--r--gnome-extra/zeitgeist-datahub/zeitgeist-datahub-0.9.5.ebuild51
3 files changed, 69 insertions, 0 deletions
diff --git a/gnome-extra/zeitgeist-datahub/Manifest b/gnome-extra/zeitgeist-datahub/Manifest
new file mode 100644
index 000000000000..d0ba6bd0e14c
--- /dev/null
+++ b/gnome-extra/zeitgeist-datahub/Manifest
@@ -0,0 +1 @@
+DIST zeitgeist-datahub-0.9.5.tar.gz 214258 SHA256 96794d785511242680b940f9c090cb393499f285eef2c79b5190cc131c16222f SHA512 2aef90cb6d6b448d6f69f805149a4743cc27db4195b4d6d5b08cc48f95443f67379b9301387e2ec2dd9954726841f11d7750d6b8868ba571b9537005dc09bae4 WHIRLPOOL acc83b1051af38babb604c1e31513fdab1e1050930832e62019438d8026f06fe2831a76ad2b8f3138f4f53cb8d24a5ac0a6ec779a6ad7ad23e238aebac8b0d7e
diff --git a/gnome-extra/zeitgeist-datahub/metadata.xml b/gnome-extra/zeitgeist-datahub/metadata.xml
new file mode 100644
index 000000000000..a17089d0f01e
--- /dev/null
+++ b/gnome-extra/zeitgeist-datahub/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="download">Monitor XDG download directory</flag>
+ <flag name="telepathy">
+ Telepathy logging support for 1-to-1 chats, calls and file transfers
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">zeitgeist-datahub</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gnome-extra/zeitgeist-datahub/zeitgeist-datahub-0.9.5.ebuild b/gnome-extra/zeitgeist-datahub/zeitgeist-datahub-0.9.5.ebuild
new file mode 100644
index 000000000000..e4f343775b12
--- /dev/null
+++ b/gnome-extra/zeitgeist-datahub/zeitgeist-datahub-0.9.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+VALA_MIN_API_VERSION=0.16
+
+inherit autotools-utils versionator vala
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Provides passive plugins to insert events into zeitgeist"
+HOMEPAGE="http://launchpad.net/zeitgeist-datahub"
+SRC_URI="http://launchpad.net/zeitgeist-datahub/${MY_PV}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="download telepathy"
+
+CDEPEND="
+ !>=gnome-extra/zeitgeist-0.9.12
+ dev-libs/libzeitgeist
+ >=dev-libs/json-glib-0.14.0
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ telepathy? ( >=net-libs/telepathy-glib-0.18.0 )"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}
+ $(vala_depend)
+ virtual/pkgconfig"
+PDEPEND="gnome-extra/zeitgeist"
+
+src_prepare() {
+ sed \
+ -e '/Encoding/d' \
+ -i src/${PN}.desktop.in || die
+ rm -f src/zeitgeist-datahub.c || die
+ vala_src_prepare
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable telepathy)
+ $(use_enable download downloads-monitor)
+ --disable-silent-rules
+ )
+ autotools-utils_src_configure
+}