summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-13 19:28:58 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-13 19:21:32 -0400
commit2ab44c82bf14ee28189692d02557bda820d39d19 (patch)
tree6b7c66fb7ea0f3c2741bff3d9413d31862a17246 /gnome-extra
parentvirtual/editor: Add Helix (diff)
downloadgentoo-2ab44c82bf14ee28189692d02557bda820d39d19.tar.gz
gentoo-2ab44c82bf14ee28189692d02557bda820d39d19.tar.bz2
gentoo-2ab44c82bf14ee28189692d02557bda820d39d19.zip
gnome-extra/gnome-system-monitor: Version bump to 44_rc
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30108 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest1
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-44_rc.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
index 9c17462bb670..515998ac832d 100644
--- a/gnome-extra/gnome-system-monitor/Manifest
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -1 +1,2 @@
DIST gnome-system-monitor-42.0.tar.xz 978208 BLAKE2B ba52048e643eef1dd556dc833fc5ebdf6a07559551c5e28dc46c3d143676571f7704667263f9974d87d6ed3679c15c955178a02e9ed5f69b4bc25c78d9b32e4e SHA512 880093fd75a87993ff8def1db9f6f090edaad43c6dc08564f61b9dbfa8c10df5e6d6a9a9072737d802503b34ba70de7bf7ef5aab2bf055ea68e795ec11a48bdd
+DIST gnome-system-monitor-44.rc.tar.xz 1012032 BLAKE2B 51e77c5dfdeb1da5656b6b257183180a714d0780a242cb67a55941dc435b82299099d9b0e71350b6988030bee539a6e6acbcaeb1efc5090508fba3c284ebbbfc SHA512 df37c3b5b5815b65641ec783928d5880db33fd5d5b3a47670555369e51fb11e08cab75bfc2523e45146dd334972d82aeb7f4176fdedf04cbaa07578a8de23ddf
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-44_rc.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-44_rc.ebuild
new file mode 100644
index 000000000000..72774afae814
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-44_rc.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/stable/"
+SRC_URI="https://download.gnome.org/sources/${PN}/44/${PN}-44.rc.tar.xz"
+S="${WORKDIR}/${PN}-44.rc"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.46:2
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.22:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/atkmm-2.28:0
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gui-libs/libhandy-1.5.0:1=
+ >=gnome-base/librsvg-2.35:2
+ >=dev-libs/libxml2-2.0:2
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+ systemd? ( >=sys-apps/systemd-44:0= )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ >=sys-auth/polkit-0.114
+" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use X wnck)
+ $(meson_use systemd)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}