summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-05-17 22:15:37 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-05 21:55:35 -0400
commitd9417ccd32203674221f957f07db7108f7ffd2e2 (patch)
tree51450b85f35af3c821313dbc7bc730e1e16d28f0 /gui-apps/lavalauncher/files
parentgui-wm/hikari: new wayland window manager (diff)
downloadgentoo-d9417ccd32203674221f957f07db7108f7ffd2e2.tar.gz
gentoo-d9417ccd32203674221f957f07db7108f7ffd2e2.tar.bz2
gentoo-d9417ccd32203674221f957f07db7108f7ffd2e2.zip
gui-apps/lavalauncher: new wayland application launcher
Closes: https://bugs.gentoo.org/723524 Minimalistic and simple launcher for Wayland. It serves a single purpose: Letting the user execute shell commands by clicking on icons on a dynamically sized bar, placed at one of the screen edges. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/15861 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps/lavalauncher/files')
-rw-r--r--gui-apps/lavalauncher/files/lavalauncher-1.7.1-optional-man.patch27
-rw-r--r--gui-apps/lavalauncher/files/lavalauncher-remove-werror.patch12
2 files changed, 39 insertions, 0 deletions
diff --git a/gui-apps/lavalauncher/files/lavalauncher-1.7.1-optional-man.patch b/gui-apps/lavalauncher/files/lavalauncher-1.7.1-optional-man.patch
new file mode 100644
index 000000000000..612548e17a78
--- /dev/null
+++ b/gui-apps/lavalauncher/files/lavalauncher-1.7.1-optional-man.patch
@@ -0,0 +1,27 @@
+diff --git a/meson.build b/meson.build
+index 029f711..50beccd 100644
+--- a/meson.build
++++ b/meson.build
+@@ -6,7 +6,6 @@ project(
+ default_options: [
+ 'c_std=c11',
+ 'warning_level=3',
+- 'werror=true',
+ ]
+ )
+
+@@ -61,6 +60,7 @@ scdoc = dependency(
+ 'scdoc',
+ version: '>=1.9.2',
+ native: true,
++ required: get_option('man-page'),
+ )
+ if scdoc.found()
+ scdoc_prog = find_program(scdoc.get_pkgconfig_variable('scdoc'), native: true)
+diff --git a/meson_options.txt b/meson_options.txt
+new file mode 100644
+index 0000000..2e41905
+--- /dev/null
++++ b/meson_options.txt
+@@ -0,0 +1 @@
++option('man-page', type: 'feature', value: 'auto', description: 'Generate and install man pages')
diff --git a/gui-apps/lavalauncher/files/lavalauncher-remove-werror.patch b/gui-apps/lavalauncher/files/lavalauncher-remove-werror.patch
new file mode 100644
index 000000000000..3be85ab800c6
--- /dev/null
+++ b/gui-apps/lavalauncher/files/lavalauncher-remove-werror.patch
@@ -0,0 +1,12 @@
+diff --git a/meson.build b/meson.build
+index 317eeec..560421d 100644
+--- a/meson.build
++++ b/meson.build
+@@ -6,7 +6,6 @@ project(
+ default_options: [
+ 'c_std=c11',
+ 'warning_level=3',
+- 'werror=true',
+ ]
+ )
+