summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-12-13 10:12:23 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2024-12-13 10:14:47 +0000
commite05e306a7b00145a88c6d57956ed85f2e3af7fae (patch)
tree54552ab6bbe4e67709ed4fec830df8a02cb770ce /gui-apps/wayvnc
parentgui-libs/neatvnc: add 0.9.2 (diff)
downloadgentoo-e05e306a7b00145a88c6d57956ed85f2e3af7fae.tar.gz
gentoo-e05e306a7b00145a88c6d57956ed85f2e3af7fae.tar.bz2
gentoo-e05e306a7b00145a88c6d57956ed85f2e3af7fae.zip
gui-apps/wayvnc: add 0.9.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps/wayvnc')
-rw-r--r--gui-apps/wayvnc/Manifest1
-rw-r--r--gui-apps/wayvnc/wayvnc-0.9.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/gui-apps/wayvnc/Manifest b/gui-apps/wayvnc/Manifest
index 4836c47edd4a..c6542d27f051 100644
--- a/gui-apps/wayvnc/Manifest
+++ b/gui-apps/wayvnc/Manifest
@@ -1 +1,2 @@
DIST wayvnc-0.8.0.tar.gz 101120 BLAKE2B c4d6a338bdc4d6672e6238f4d0364294a29c69e2b034ea03c90b36f6280fc8f6d2a35101fa5650a75be4b2d360b402d913c787e86088bd11188e8e38f4380873 SHA512 88971d276cf6695a446fc746fa1eae1f4df2b5ba42cabf7b7c57481a89af95fe60fce5e1c92bc10e4c871bf561da0d9bb2117418e971a9b4bc6f46b9e53db74d
+DIST wayvnc-0.9.1.tar.gz 117503 BLAKE2B 64702ff290776eb2fde8002615c791853d1158465229a3136655c05de50f34f1214c851888679c1e1949500c90aaa51ce460b07fc5658edf043eff0d46971c2d SHA512 f09cf085265dd5657c4c5db66d68715aa63abd7f59508b917116b7626a30debff01a271a3fbc147a9884bd0ea8e4870e2118c2dc259d90ae674b12fa8e763980
diff --git a/gui-apps/wayvnc/wayvnc-0.9.1.ebuild b/gui-apps/wayvnc/wayvnc-0.9.1.ebuild
new file mode 100644
index 000000000000..7dbaf113dda2
--- /dev/null
+++ b/gui-apps/wayvnc/wayvnc-0.9.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="gbm pam test tracing"
+
+RDEPEND="
+ =dev-libs/aml-0.3*
+ dev-libs/jansson:=
+ dev-libs/wayland
+ =gui-libs/neatvnc-0.9*
+ media-libs/mesa[egl(+),gles2(+),gbm(+)?]
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ pam? ( sys-libs/pam )
+ tracing? ( dev-debug/systemtap )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature pam)
+ $(meson_feature gbm screencopy-dmabuf)
+ $(meson_use tracing systemtap)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}