summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-09-23 18:54:20 -0600
committerSam James <sam@gentoo.org>2023-09-25 05:48:42 +0100
commit8d6d07f955dd90780a95e8530760dba18a914594 (patch)
treeee69a7757e84bf8b885a786fbbded3f2c2f024c9 /gui-apps
parentgui-apps/wl-clipboard: fix install on Prefix (diff)
downloadgentoo-8d6d07f955dd90780a95e8530760dba18a914594.tar.gz
gentoo-8d6d07f955dd90780a95e8530760dba18a914594.tar.bz2
gentoo-8d6d07f955dd90780a95e8530760dba18a914594.zip
gui-apps/wl-clipboard: update EAPI 7 -> 8
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/32919 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-2.2.1-r1.ebuild34
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-9999.ebuild2
2 files changed, 35 insertions, 1 deletions
diff --git a/gui-apps/wl-clipboard/wl-clipboard-2.2.1-r1.ebuild b/gui-apps/wl-clipboard/wl-clipboard-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..a6e795516423
--- /dev/null
+++ b/gui-apps/wl-clipboard/wl-clipboard-2.2.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+ SRC_URI="https://github.com/bugaevc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dfishcompletiondir="${EPREFIX}/usr/share/fish/vendor_completions.d"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild b/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
index 4da7e621a301..5f2e91e8c06d 100644
--- a/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
+++ b/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson